Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have created a custom post type and disabled it from appearing in search results. However when I add a link from a normal post, I still get these entries from my custom post type available to link to in the internal linking box (at the bottom when of the popup when you click the link button in the editor). How can I disable the custom post type from displaying entries there as well?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I suggest making it private ('public' => false when registering the post type). You could club it with 'show_ui' => true to still display the admin interface.

See the codex for register_post_type for full reference http://codex.wordpress.org/Function_Reference/register_post_type

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.