Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a weird problem, which I could not solve yet. I installed wordpress 3.4.1 and made an own template. I use one plugin - qTranslate. Everything is fine on my local copy and also on my dev copy dev.mysite.cz.

When I copied wordpress and log in on the main site, http://www.mysite.cz, the dashboard does not show up. Instead I only get the homesite with the administration panel on top of the page.

The only difference I can so far tell is in the wp-config.php file. In production mode I have this two more directives in it:

/** debugging mode */
define('WP_DEBUG', false);

/** Localisation */
define('WPLANG', 'cs_CZ');

Any advice will be very appriciated. Thanks

share|improve this question
    
the last time i had similar problem, it was due to .htaccess file. Fixed by renaming .htaccess to .htaccess.backup –  Mridul Aggarwal Oct 22 '12 at 20:39
    
Isnt the .htaccess file necessary? –  Santhos Oct 24 '12 at 12:10

2 Answers 2

When you say "copied" Wordpress, what do you mean?

Do you mean,

A) I copied my entire Wordpress installation folder to my new server location?

B) I copied ONLY my custom theme folder to my new server location?

If your answer is A then we can assume you did not install a fresh copy of Wordpress on your server before migrating.

If your answer is B then we can assume you already installed a fresh copy of Wordpress before migrating your theme.

B is the correct method unless you are using a specially designed migration plugin that helps you move your installation from location to location. Or unless you know how to manually work with your SQL file while ensuring to update any relevant URLs within that need changing to match the new destination.

If not, then the URLs that tell Wordpress where to expect certain areas like the admin dashboard, might still be pointing to your previous location.

Try adding the following lines to your functions.php file,

update_option('siteurl','http://example.com/');
update_option('home','http://example.com/');

Replace the URL above with your current site URL. Save the file. Then revisit your login page. If it does not show up, refresh it a couple times. If it then shows up, we know this was the problem. You can now login to your site.

Once logged in, remove the entries in your functions.php file that you placed earlier. Then goto settings -> general and make sure the URLs you see for site/home address match what you entered manually into functions.php before! It should match. But check it anyway to make sure.

share|improve this answer
    
I used method A and I have updated both siteurl and home. I am not a WP beginner, but this is really magic I do not understand. –  Santhos Oct 24 '12 at 12:12
up vote 0 down vote accepted

The problem was in .htaccess. There was an old global .htaccess file (from the old website) besides the wordpress one which was hidden on the sever (by admins of the hosting company) which rewrite rules harmed the ones in wordpress. I actually had to contact the admins and ask them to remove those rewrite rules.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.