Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I use .html on PAGES plugin, and this works fine for me in Chrome and Firefox.

However, Internet Explorer displays "page cannot be found".

Why would one browser not display a page, but two others find it?

Problem pages are:

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

You are sending a very confusing response:

HTTP/1.1 301 Moved Permanently
Date: Sat, 20 Oct 2012 12:33:06 GMT
Server: Apache
X-Powered-By: PHP/5.3.13
X-Pingback: http://tech.doig.com.au/xmlrpc.php
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: text/html; charset=UTF-8

After that the regular page content follows.

So in your first line you tell the browser to look elsewhere for the content. But you don’t say where, there is no Location header. And then you send the content?

Fix the HTTP header: send a proper status code (200), or a Location header with an URL for the new address.

share|improve this answer
    
Thanks toscho. What tool did you use for this? I have an .htaccess file (pastebin.com/RLUutcgA) which redirects portfolio.html, but only if the host is steve.doig.com.au, not tech.doig.com.au (I once moved my web design site from steve.doig.com.au to tech.doig.com.au). –  Steve Oct 21 '12 at 9:27
    
@Steve I hit Ctrl Shift i in Opera. Screen shot. I don’t think it is a .htaccess problem. There is probably a broken plugin calling wp_redirect() without exit afterwards. Disable all plugins and check again. –  toscho Oct 21 '12 at 9:36
    
Thanks, I found the Network tool in Chrome too. I disabled all plugins, refreshed the page, and the network tool shows there is still a 301 redirect on portfolio.html. –  Steve Oct 22 '12 at 10:43
    
Then it is a result of the way the .html on PAGES plugin works. Looking at the code I see it does almost everything wrong it can do. Find a better plugin. –  toscho Oct 22 '12 at 12:54
    
That makes sense. Thanks. –  Steve Oct 24 '12 at 13:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.