Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

We have a multisite setup, the primary site needs to have example.com, www.example.com and secure.example.com mapped in wordpress so the primary site's content loads on them.

secure.example.com will be over HTTPS.

The problem we are facing is everything except secure.example.com works. When attempting to access https://secure.example.com there is a 302 redirect to: http://www.example.com/wp-signup.php?new=secure.example.com secure.domain.com has a SSL Certificate to server secure content. Obviously it can't just redirect otherwise it wouldn't be secure any longer.

WordPress MU Domain Mapping is installed but doesn't appear under the primary site's menus. When trying to access the plugin directly via ~/wp-admin/tools.php?page=domainmapping we recieve the message

"You do not have sufficient permissions to access this page."

Note: We are logged in as Super Admin.

Any suggestions regarding to this would be highly appreciated.

share|improve this question
    
The domain mapping page will only be visible under Network admin > Settings /wp-admin/network/settings.php?page=dm_admin_page unless the "User domain mapping page" option is selected. –  Milo Oct 17 '12 at 15:31
    
Sorry, I should have clarified. This occurs when I try going under the primary site in the network's admin area, logged in as super admin. It's wierd because the other sites in the network show the Domain Mapping page, but the primary site does not. –  Jerry Tunin Oct 17 '12 at 16:48
    
you can't map the primary site to another domain, only sub-sites. –  Milo Oct 17 '12 at 16:55
    
I just need to map/mirror secure.domain.com to the primary site so order forms are over ssl. –  Jerry Tunin Oct 17 '12 at 18:43

1 Answer 1

up vote 0 down vote accepted

In the end I ended using mod_rewrite through .htaccess. The following is what I am using and so far is working well.

RewriteCond %{HTTP_HOST} ^secure\.domain\.net$
RewriteRule (.*) http://www.domain.net/$1 [P,L]
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.