Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Please help me out.. I had uploaded new theme(child theme) in clients server.Theme folder has twenty ten and child theme now.But when i activated the theme in admin side ,the twenty ten shows the corresponding child theme and the new one shows the html template (from that html template i made the corresponding wordpress theme).Is this the problem with uploading? what went wrong ?

share|improve this question
    
Still fuzzy. :) Could you please rephrase - what does twenty ten shows and new one shows the html template mean? –  Rarst Jan 13 '11 at 7:59
    
Can you give us the file listing of the themes directory? Perhaps your html template is in the way of something? –  Jan Fabry Jan 13 '11 at 8:31
    
Actually client uploaded the wordpress in his server and asked me just upload the child theme i did .there were two themes 'ken' and 'twentyten' in theme folder.He told me to upload the theme in ken folder.i did it like that and change theme name in style.css to ken. –  treesa Jan 13 '11 at 9:58
    
hey am new to wp..plz forgive if am confusing u all.. –  treesa Jan 13 '11 at 10:04
    
Can you edit your question to include the list of files you now have in the ken directory? And the heading (first comment block) in the style.css of your ken theme? –  Jan Fabry Jan 13 '11 at 13:59
add comment

1 Answer

Codex has some step by step instructions on manual theme upload.

In case of issues it is also worth checking if theme structure and meta information are adequate and in line with technical requirements.

There is also Theme Check plugin for automated testing, but it's unlikely to help if WP can't properly detect theme.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.