Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have WordPress installs in my IIS localhost server on Win7 desktop done manually and with WebPI install.Both installs are under IIS default website.

Either asks for FTP credentials when I try to auto update to the latest WP version. I have FTP server enabled on IIS (users IUSR and Richard).

I have checked that read write permissions are enabled on the wordpress root & wp-content folders.
I try putting in the credential values but keep getting no response or

ERROR: There was an error connecting to the server, Please verify the settings are correct.

Credentials asked for are Hostname/FTP user/FTP password and I have tried all manner of credentials I think might be correct but obviously are not. (eg ftp://localhost- IUSR -site password etc etc). I am most unsure about the FTP password.

I have asked for help with this on WordPress forum, WordPress codex, IIS7 forum, googled & tweeted for help to fix this and found no answer! There are several threads about the issue but most say the fix is to enable read write folder permissions and there is something about using web.config file and also editing wp-config.php. I do not really want to edit wp-config.php. What I really want is to enter the correct ftp credentials for WordPress on IIS and have it work and autoupdate to the latest version.

Does anyone know what ftp credentials I have to use to get this done please? Has any WordPress IIS localhost user experienced this and dealt successfully with this ftp autoupdate?

Edit 10/10/12 >> Hi mauri- many thanks for your very helpful reply. I followed your instruction on my WordPress blog that MS WebPlatformInstaller(WPI) installed for me and (ta da!) it worked as you said-ie it autoupdated to the latest WP version without asking for the ftp credentials. My only issue is I'm not sure what this is or what I really did apart from following your instruction! I would like to understand all this 'jiggery-pokery'! I add Authenticated users & gave them full permission. I would also really like to fully understand my localhost IIS server...I would also like to know how to set my IIS up so when asked for the ftp credentials I can put in the info & have it work that way too! However very many thanks for your very helpful reply

share|improve this question
    
I have updated my answer.. glad that help you... Remember to mark it as accepted answer clicking on the left arrow.. –  mauri Oct 11 '12 at 2:33
    
Thank you for the clarification on IIS Permissions for my WordPress site. In my circumstance, WordPress on Windows 7 simply would not auto-update. Turns out the Write permission was unchecked and once I set it WordPress 3.8.2 installed properly. –  user50123 Apr 9 at 0:35
add comment

2 Answers

FTP credentials are fallback for when writing directly to the file system is not available. Naturally they take active FTP (or SSH) server - which is typical for any hosting out there, but not necessarily part of local installation.

Essentially you have two options:

  1. Troubleshoot why direct file system access is not available to your WP installation. On WordPress side Core Control plugin would be a starting point.

  2. Configure FTP server in IIS, see its documentation for specifics (it seems depending on IIS version you might need to download and install some stuff for it first).

I never had serious filesystem access issues on Windows, but I am running Apache stack myself. Might be some IIS-specific quirk.

share|improve this answer
    
Hi many thanks for your reply. The reply by mauri fixes the updating issue for me (by bypassing the need to use ftp credentials).Plugins for me are ok if really needed but understanding the code & direct coding if possible is much more satisfactory imho. I do really need & want to understand more about IIS localhost server.Other Windows & WordPress users have faced this problem yet nowhere can I find the simple answer to this....strange! Anyway thanks & best wishes to you :-) –  rpd Oct 10 '12 at 8:19
add comment

You could also try this.

On the application pool that is using the blog, change the identity to LocalSystem, then on Sites,

  1. Choose your wpblog
  2. Right Click and click on Edit permissions
  3. On security tab, add authenticated users

With that, WP should update without the need of FTP Passwords...

Basically you just give read/write permission to an authenticated user... WP is running as a LocalSystem User.

To learn more about ftp configuration you can go to this Microsoft article. http://technet.microsoft.com/en-us/library/cc771012(v=ws.10).aspx Also, here there is a blog post showing how to install/configure FTP server...

If you are not able to set it up, you can also install another ftp server.. Ie: Filezilla FTP server, you can get it free from here http://filezilla-project.org/download.php?type=server

About the IIS configuration.. you can learn the how to's here http://www.iis.net/learn/manage

share|improve this answer
    
Hi mauri-many thanks for your helpful reply & instruction (which worked!).Please see the edit (today 10/10/12) to my original query above-many thanks again :-) –  rpd Oct 10 '12 at 8:05
1  
@rpd if answer had solved your issue please accept it (check mark to the left of it) so question is marked as resolved –  Rarst Oct 10 '12 at 10:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.