WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Wordpress 3.4.1 installed on a local WAMP server.

I am in the process of upgrading it to a network, but I now realise my admin account has no admin privileges:

  1. No access to the Updates page (update-core.php) - I receive "You do not have sufficient permissions to access this page."
  2. No ability to install plugins.
  3. No ability to edit users.
  4. No ability to go to Tools > Network Setup - same error as above.

    • The wp_capabilities of my user account is a:1:{s:13:"administrator";b:1;}
    • The wp_user_level is 10

What is wrong here?

Update - I added another admin account using PHPMyAdmin following this tutorial, but I receive the same symptoms for this 2nd admin account.

share|improve this question

This sounds like a Folder Permissions problems - the MAMP Apache user needs to have read/write privileges on everything under your Sites/wordpress/ folder.

This is easy to do from the terminal ... my post on Permissions should help can i run wp as root permissions

share|improve this answer
Does your solution work in a Windows WAMP environment? – Steve Oct 7 '12 at 10:18
The solution applies to any server setup .. Linux, mac, windows. Folder permissions and ownership are crucial to making Wordpress work. – Damien Oct 7 '12 at 10:52
How do I know what user is running Wordpress? Is it Apache? There is no such user in the Windows OS. Do I have to create a Windows user called Apache, and provide it with permissions to the Wordpress folder? – Steve Oct 10 '12 at 12:00
Hi ... WAMP creates a user called WAMPAPACHE. This answer on SO might help you to identify the user and change it to your name. Your 'wordpress' folders are probably owned by 'you' and 'wampapache' needs to have ownership of these. – Damien Oct 10 '12 at 12:35
There has been no new user account created on the computer after installing WAMP, and there is no user account with wamp in it. – Steve Oct 10 '12 at 13:27
up vote 0 down vote accepted

I've just done a new install of a newly download zip file, and the installation process stops at:


This page is blank, and nothing progresses.

I now recall this happened on my previous installation also.

If I refresh this page, I receive a message: "Already Installed You appear to have already installed WordPress. To reinstall please clear your old database tables first."

I can elect to log in from here, and doing so presents me with the ability to install Plugins, which I can't do on my other installation.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.