Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

If an unregistered user/stranger try to view a post it says

"You must be registered or logged in to view the post".

http://testandverification.com/events/dvclub-august-2012-on-sv-uvm/

We have a category (for private posts) to allow only some registered users to access some posts.

Even though posts are not included in that category, it shows the above message.

How to allow unregistered users/strangers to view public posts?

I did the following on my test server.

I disabled all the plugins and switched my theme to twentyeleven.

In that twentyeleven theme everything is fine - stranger can able to access posts.

When I switch the theme to our custom theme and without enabling the plugins, the issue re-occurs.

Then I thought that the problem is not with plugin so I tried to compare the theme code with an early release and found that it is the same as before.

I loaded a old DB backup in the test server and I was surprised that it worked correctly!

When I tried to recreate the missing posts between the old DB and current DB, I got the same problem.

It is strange and I felt happy when I traced the problem in the DB and now I have lost the confidence of tracing the bug.

share|improve this question

closed as too localized by Rarst Oct 12 '12 at 13:51

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 0 down vote accepted

It is a strange and rare bug.

While publishing our last post we checked the "Blog" and some other categories in the category section.

In our previous posts we never checked the "Blog" category.

Initially, when I tried to reproduce the bug, I didn't noticed it.

We again tried to reproduce the bug and this time we have identified the bug.

I am not sure whether the bug is in wordpress or our site development team.

I wonder how checking a category affects the behavior of "Strangers"!

If any one know where the bug actually lies, please let me know.

We have corrected the problem in our site and the above link is now working fine.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.