Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am building a website using wordpress and i am planning to use Nextgen Gallery in order to show some pictures on a page.

My issue is, when i upload an image which has a filename containing greek characters, it doesn't show properly. Actually it doesn't show at all.

The filename on the server is saved as %ce%bf%cf%81%cf%84%ce%b1%ce%bd%cf%83%ce%b9%ce%b1

The img src on the page appears to be ok, as %ce%bf%cf%81%cf%84%ce%b1%ce%bd%cf%83%ce%b9%ce%b1.jpg

But the image doesn't show at all (is broken) and when i click "Open in a new tab", it returns the path of the image, but with the greek characters this time, like http://localhost/wordpress/wp-content/gallery/test/ορτανσια.jpg

How should i fix this issue?

Kind regards.

share|improve this question
add comment

1 Answer 1

I would check the encoding on the database. Make sure it's set to utf-8 unicode

Edit: Here is an article for more indepth reading: http://www.informit.com/articles/article.aspx?p=328641

Also taken from here

The reason why I suggest you check the encoding is because if you insert something into a database with encoding set to ISO 8859-7 Greek, then it is going to interpret the characters as greek.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.