Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Tried to install a wordpress plugin on my local machine:

To perform the requested action, WordPress needs to access your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host.

Hostname          127.0.0.1
FTP Username      macusername
FTP Password      macusernamepassword
Connection Type   Connection Type  FTP

When I click proceed, I get this:

Failed to connect to FTP Server 127.0.0.1/:21

Why doesn’t WordPress work with my FTP data?

share|improve this question

4 Answers 4

up vote 3 down vote accepted

Depending on your version of OS X, you will need to configure and run FTP and open a port in the firewall. It's best if you google your OS X version - 10.6, 10.7, etc. - specifically and find the docs necessary to set up FTP and Sharing.

You also need to realize the security implications of opening up FTP to your local machine; someone port scanning your IP may be able to find your FTP port.

It's often easiest - and the best for security - to simply download the plugin and move it into the plugins folder.

share|improve this answer

Are you using Lion? If so, Apple dropped support for managing the FTP service via the Sharing settings. But the underlying service is still available. You can manually enable it by running this command in the terminal

sudo launchctl load -w /System/Library/LaunchDaemons/ftp.plist

Then you can stop and start the service like this:

sudo launchctl stop com.apple.ftpd

sudo launchctl start com.apple.ftpd

I would actually recommend that you run Apache as your currently logged in user instead (thus avoiding the FTP requirement completely), since this is your local machine and it's for development purposes. You just need to modify your httpd.conf file which is located at /etc/apache2/httpd.conf.

Change:

User _www
Group _www

To:

User yourshortname
Group staff

Then just restart Apache by running the command: sudo apachectl restart and then enter your password.

share|improve this answer

You could also just unzip the plugin package and paste it in the plugins directory. Then activate the plugin in the plugins area of your wordpress backend.

share|improve this answer

change to the directory of your web server lets say wordpress inside it and run the command

chown -R www-data:www-data

This will do everything and you wont get the error message again

share|improve this answer
    
No. This is dangerous advice. That could actually break a lot of things. The user and group names-- in your example both "www-data"-- are not universal. The defaults vary by *nix distro and can be changed by an administrator. And the the two do not even need to match. Change the user:group to the wrong values for your server and things break. Secondly, this probably has nothing to do with the actual FTP connection, which is where the error indicates a problem, though it would effect the ability to transfer files. –  s_ha_dum Dec 22 '12 at 15:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.