Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have searched various forums and blogs, however I could not find the isuse so far, neither a way to fix it.

item does not seem to be a wordpress-reserved word.

My custom post type registers just fine. I can work with it from admin, edit, delete, preview, assign terms, publish... .

However any time I try to visit the permalink (e.g. http://www.example.com/item/test-item-77/) it goes to the 404 page!

Had someone tried this out with the latest version of WP?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Try updating your permalinks in the backend under Settings -> Permalinks. Be sure to "Save Changes" even if you don't make any changes. It seems to refresh the permalinks.

Also verify the "slug" is set properly when you're setting up your post type.

share|improve this answer
    
tried this, not working –  adrian7 Sep 21 '12 at 6:33
    
Could you post the code you're using for register_post_type()? –  Dave Hunt Sep 21 '12 at 12:56
    
I found the problem, there was this plugin: wordpress.org/extend/plugins/kih-web-directory-wordpress-plugin . Once I deactivate it the permalinks are working. –  adrian7 Sep 21 '12 at 18:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.