Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have installed wordpress on my dev but during installation, I did not upload any picture for my profile but on admin bar, it is showing my picture. How I can remove it?

share|improve this question
    
picture is same as on my stackoverflow account –  baig772 Sep 19 '12 at 22:52

2 Answers 2

up vote 3 down vote accepted

That's a gravatar. Change your user email to another email that is not registered at gravatar, or change the image to a blank .jpg at https://en.gravatar.com/

share|improve this answer
    
has it right. Also worth noting, you're the only person who will see your picture, and then only when you're logged in. The only place your users might see it is if they have administrator-level WordPress accounts on your site and are able to look at the full 'Users' page where I think the photos also display. But they will not see it in the top admin bar ever. –  Michelle Sep 19 '12 at 23:08
    
yes but client is also seeing my picture –  baig772 Sep 19 '12 at 23:12
1  
I think anyone will see the image, as any web site that has a registration with that email will query gravatar.com for the image. –  songdogtech Sep 19 '12 at 23:15
    
changed the email address and it worked –  baig772 Sep 20 '12 at 0:10

(...) but client is also seeing my picture

- OP in a comment

If you want to disable it completely, the following should work (wrote a little (MU-)Plugin for you):

<?php
! defined( 'ABSPATH' ) AND exit;
/* Plugin Name: (#65698) »kaiser« Disable Avatar */
add_filter( 'get_avatar', '__return_null' );

Just drop it into your plugins or mu-plugins folder, activate it in your client installations and you disabled the gravatars successfully.

share|improve this answer
1  
that's very nice of you @kaiser but I have to change the email address to my official email address and it worked. In future, will definitely use yours –  baig772 Sep 20 '12 at 0:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.