Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've been working on a Wordpress site for a while and have gone to make it live this afternoon.

After following this tutorial video (http://www.youtube.com/watch?feature=player_embedded&v=cM9Z8aQTCvQ), I went into settings on my localhost installation and changed them to my live site, therefore my local Wordpress installation no longer works.

Is there an easy way to access that page and point Wordpress locally again? The upload didn't work out so I decided to just do a manual re-install.

share|improve this question

migrated from stackoverflow.com Sep 19 '12 at 19:46

This question came from our site for professional and enthusiast programmers.

2 Answers 2

It sounds like your wordpress install just doesn't know where it is living. Make sure your wp_config.php file has the right info for connecting to your local database first off.

Next you'll need to use phpMyAdmin or a similar database management tool to edit 2 rows in the "wp_options" table of your wordpress database.

The first row starts with "site_url", and is on the first page of table rows typically. The second row you want to change is the "home_url", and it is typically on the second page of table results.

For those two rows you generally enter the server url that you use to access your local wordpress install, ie "http://localhost/", or "http://localhost:8888/".

share|improve this answer

I think what you need to do to get the local install back up and running is either edit some database files manually, or make a couple changes to the wpconfig.php file in the root of your wp install.

check out this codex page for instructions on editting this file.

You will need to make sure your database credentials are correct of course, but you will also want to set the site_url and I think the Blog Address.

After the local install is back up and running, you should be able to access the settings page again, and set these 2 addresses properly, after which you should remove those lines from wp-config.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.