Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

This one has me stumped

I'm sure it is something really small that I am overlooking but I think I've been looking at it too long to see what the problem is.

Wordpress is telling me:

"Upload folder is not writable. Export and file upload features will not be functional."

Well...specifically it is Gravity Forms that is producing that error message, but uploading media isn't working either.

Here's what I've checked:

  1. Uploads folder and all sub-folders permissions are set to 755
  2. Uploads folder has same owner and group as every other script
  3. Upload folder setting on Settings->Media page has been set to: empty and wp-content/uploads (with and without trailing slash)

I'm not sure where to go from here. What am I missing?

share|improve this question
1  
possible duplicate of Can't upload images due to permissions error –  Chris_O Sep 12 '12 at 17:39
    
Jeff, glad to have you at WordPress Answers. There are many, many questions that have already been answered here regarding this topic. wordpress.stackexchange.com/search?q=uploads+permissions For future reference, it's best to search first and ask questions later. –  Brian Fegter Sep 29 '12 at 5:17
1  
Hi Brian, Thanks for your input. I did in fact search first and had tried all the remedies I felt applied to my situation. It seems odd that you would post on this topic so long after it had been answered AND someone else had marked it as a possible duplicate. I'm not someone that posts a question so someone else can find the answer for me. I'm also not someone that posts on month old, already answered topics to increase my post count. –  Jeff Purcell Oct 1 '12 at 16:05
    
FTR, just ran across this exact same issue specifically in regard to using the Gravity Forms Plugin. Added the plugin, message appeared. Removed the plugin, message disappeared. Searched for help, found this thread in the results specifically because it mentions the Gravity Forms Plugin that I was searching for along with the generic error message. Jeff thanks for posting. –  Joel Glovier Oct 26 '12 at 20:46

2 Answers 2

up vote 3 down vote accepted

That's a server permission problem. According to the WP docs:

Any file that needs write access from WordPress should be owned or group-owned by the user account used by the WordPress (which may be different than the server account). For example, you may have a user account that lets you FTP files back and forth to your server, but your server itself may run using a separate user, in a separate usergroup, such as dhapache or nobody. If WordPress is running as the FTP account, that account needs to have write access, i.e., be the owner of the files, or belong to a group that has write access. In the latter case, that would mean permissions are set more permissively than default (for example, 775 rather than 755 for folders, and 664 instead of 644).

From http://codex.wordpress.org/Changing_File_Permissions

So you need to check with your webhost. Who is the host?

You can try setting the Gravity Forms uploads folder to 777 and try uploading, and the set them back to 755 if it works/doesn't work. Bumping perms to 777 for a moment sometimes will toggle the correct permissions on some webhosts and then 755 will work afterward.

share|improve this answer
    
Changing to 775 did it. I find it odd because I was careful to make sure the same user and group had ownership of the uploads folder recursively. Thanks. –  Jeff Purcell Sep 12 '12 at 22:15

I had the same problem for few of my websites, I think it is happening because of "gravity forms" some web hosting servers with their permissions, but there is a simple trick:

  1. Go to the Plugins menu, look for the gravity forms plugin
  2. Deactivate it
  3. Update the needed plugins, or whatever
  4. Reactivate the gravity forms
  5. Done!

Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.