WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a blog installed on my site using Wordpress. Last week I upgraded Wordpress from 2.6 to 3.0.4 (I had to do this manually).

All went well, or so I thought, but I have just noticed that the content of an existing page has vanished. The page URL still works, but all content has disappeared - doctype, html tags, body tags, everything.

Please note, this is specific to pages - posts are still displaying fine.

I have since created a brand new page which does not display the content either.

Things I have tried include

* Switching to a freshly installed theme
* Reverting the page to an older version
* Deactivating all plugins
* Setting the problem page to draft, and back again
* Deleting the .htaccess file

I suspect it's a database problem and have contacted my hosting company who have said the only thing they can do is restore the DB from a backup, but that I should consider it a last resort.

Does anyone have any further ideas what to try?

share|improve this question
We'd need to see your site ... but the content should still be in the database. Is there any way you can look at the DB directly with phpMyAdmin? – EAMann Jan 6 '11 at 21:25
I can dive into phpMyAdmin, yes, and the content is still in there. – ajcw Jan 6 '11 at 21:27
have you tried resetting permalinks? – internetross Jan 6 '11 at 22:13
If its just one page... did you check to see what the Page Template was set to, and that that file exists? Although, I just checked the page link and its appears to be working, so maybe either (a) you've already figured out and fixed the problem, or (b) you were having a problem that was cached in your browser. Can you report back what the answer was, so others can learn from it? – goldenapples Jan 6 '11 at 23:00
up vote 1 down vote accepted

Thanks everyone for your suggestions - the page is now back up and running, but I am not certain why.

My theory is that I actually fixed it by deleting the .htaccess file which I removed from the root of /public_html and assumed would be recreated by Wordpress.

It's not been replaced in the /public_html folder, but without me noticing a .htaccess file was created in the /public_html/blog folder (where the blog is kept).

As I didn't notice this at first I can't be certain this was the solution, but it is my best guess.

share|improve this answer
Good to know that your problem was solved. Can you click the "accept" to indicate you don't need another answer? Welcome to this site, and I hope to see more good questions and answers from you in the future! – Jan Fabry Jan 10 '11 at 8:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.