Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

If you go to this site and click on japanese in the top left corner, it shows the japanese page with this showing up: <!--[if gt IE 8]><!--> <html class="no-js" lang="ja" dir="ltr"> <!--<![endif]--> but the actual content remains in English, other non-latin languages like हिन्दी work fine but Japanese doesnt. I have no idea why this is happening. If you need anymore info i'll be happy to provide it. P.S. QTranslate is also enabled on this site, disabling it had no effect. Using WP 3.4.2 and the latest Transposh. EDIT: DEBUG SHOWS THIS:

Notice: Undefined variable: cache_wptouch in /home/content/34/8802234/html/sarvatma/wp-content/plugins/wp-super-cache/plugins/wptouch.php on line 109

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/content/34/8802234/html/sarvatma/wp-content/plugins/wp-super-cache/plugins/wptouch.php:109) in /home/content/34/8802234/html/sarvatma/wp-content/plugins/transposh-translation-filter-for-wordpress/transposh.php on line 513

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/34/8802234/html/sarvatma/wp-content/plugins/wp-super-cache/plugins/wptouch.php:109) in /home/content/34/8802234/html/sarvatma/wp-content/plugins/transposh-translation-filter-for-wordpress/transposh.php on line 513

Notice: Undefined variable: google_font_link in /home/content/34/8802234/html/sarvatma/wp-content/themes/sarva/header.php on line 42

Notice: Undefined variable: before_widget in /home/content/34/8802234/html/sarvatma/wp-content/plugins/transposh-translation-filter-for-wordpress/wp/transposh_widget.php on line 266


Notice: Undefined variable: after_widget in /home/content/34/8802234/html/sarvatma/wp-content/plugins/transposh-translation-filter-for-wordpress/wp/transposh_widget.php on line 342
share|improve this question
    
Disable the broken WP Touch plugin (and all other plugins that are not necessary for this effect). Still broken? –  toscho Sep 9 '12 at 23:33
    
no difference. although something interesting was that when i activated qtranslate, which was deactivated a whole bunch of errors came up: pastebin.com/uqKGsYfb. I;m not sure if that's relevant. I've deactivated qtranslate anyways. Absolutely no difference to translations. I appreciate the help, man. –  theatomicdude Sep 10 '12 at 0:50
    
These notices come from sloppy code, like using $var['foo'] when there is no key 'foo'. They are probably not the cause of your problem. I guess there is an encoding problem somewhere, maybe an overly optimistic regex … but I have to pass on this. Let’s see what other members say. –  toscho Sep 10 '12 at 1:16
add comment

1 Answer 1

The before_widget and after_widget notices can go away with ease if you send those as params to the function you are using to call the Transposh widget

Update: recent version (0.9.0) fixed those notices

share|improve this answer
    
thanks, i'll do that. –  theatomicdude Sep 14 '12 at 4:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.