Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Suddenly one of my custom post types stopped working properly. More precisely, I have a custom post type called Apps where I have a few posts. Everything was working properly until I've created a new taxonomy using a plugin, then I've imported about 2-300 terms using an array in functions.php and then I've created a custom template for that taxonomy. Right after, the Apps posts couldn't be accessed anymore - even if nothing changed to them, the URL doesn't work, I get a Page Not Found error.

I reverted back to the original settings - delete the new taxonomy and terms, disable plugin, but I still get a 'page not found' error when I try to access the Apps posts.

You can see the behavior on this website.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Have you tried to update your Permalink Settings? That might sort it out. Btw. how did you named your CPT?

share|improve this answer
    
I did update the Permalinks but at the time it didn't work. Following your advice I thought about changing the permalink structure and apparently that worked. Then I switched back the permalinks to the original setting and everything works fine. Now, I'll try to include my custom taxonomy again (which is named parentalcontrol - unique name so that it doesn't interfere with anything else). –  George Grigorita Sep 8 '12 at 13:39
    
I'm glad it helped –  zigzag Sep 8 '12 at 14:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.