Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

i have my website with permalink, till now everything was fine, but few days before i changed my permalink, now everything is going wrong, now each and every page i am getting 404, even my about-us and contact us pages, they are giving me 404 page if i come to my site from google or any search engines, then also it gives me 404 i have 1000+ posts on my website, for each post & page from google i get 404 page, but within the website except pages i get no 404 page

my previous permalink: %postname%/%category%/

now i added custom taxonomy to my permalink,
so now it is:%location%/%courses%/%postname%

I asked this question first also, but it was into wrong section i guess, thats why asking again and in detail.

Related Question: custom taxonomies on permalink

share|improve this question
    
Where did you first ask that question? Please give link. –  hakre Jan 6 '11 at 13:00
    
add comment

2 Answers 2

up vote 1 down vote accepted

http://wordpress.org/extend/plugins/custom-post-permalinks/ check this plugin, I've used it on a couple of sites and it works great.

share|improve this answer
add comment

I might be very wrong on this one, but I don't think that you can add things like %location% or %courses% to your permalink structure. At least not out of nothing. So at least it looks like information about your configuration is missing to answer your question.

share|improve this answer
    
no you can add, thats the custom-taxonomy, you add that to the permalink, and it works also, because of that i am not getting 404, if i put postname in start then everything works fine –  ntechi Jan 6 '11 at 13:25
    
I then assume that your custom permalink structure is incompatible with wordpress. You should probably introduce some numeric ID with a seperator char in there to make it compatible. –  hakre Jan 6 '11 at 13:38
    
custom-taxanomies are working perfect in permalink, if i remove postname or move it to the start, then also website functions properly –  ntechi Jan 6 '11 at 13:49
    
Yes, but if you don't want to do that, you might be able to gain compatibility by adding some numerical value as a hint for the permalink resolver. That's all I meant. If you found your solution and my answer helped you in doing so, please rate it and mark it as answer. –  hakre Jan 6 '11 at 13:51
    
what numerical value to attach? and where? –  ntechi Jan 6 '11 at 13:59
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.