Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've had no problem using lightboxes before with attachment images, but I've switched to a new theme called Quicknote and it seems that attachment images now instead link to the attachment page.

However, if I change the url to the file's URL directly, any lightbox plugin works just fine. Is there an easy way to mass convert all of my posts images to the image URL instead of the attachment URL?

Even better, does anyone have any idea why I might be linking to the attachment page instead of Lightbox? Could it be a setting left ticked somewhere?

share|improve this question
add comment

1 Answer

Although it shouldn't change based on your theme, this may be an issue caused by how this new theme handles images.

As of WordPress 3.5, when you add a media object such as an image, there's a sidebar that appears on the right. Underneath the "Attachment Details" (preview, title, caption, etc.) there's a section called "Attachment Display Settings".

In this panel, look for where it says "Link To". There's a drop down box with options. Select "Media File". This should solve your issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.