Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

There are dozens of other WP installs on the same server, subject to the same ModSec rules, and none of them has a problem. This is the only WP install that has jetpack installed and it only occurs when JetPack is active. The problem is as follows:

Some actions on the post/page edit screen (so far it seems to be the ones that don't refresh the URL, like UPDATE or configure featured image) show me the following alert: http://i.imgur.com/ULPiX.png

The logs show:

Received From: kvm1->/var/log/httpd/error_log
Rule: 1002 fired (level 2) -> "Unknown problem somewhere in the system."
Portion of the log(s):
body.xml:1: parser error : Document is empty

ModSecurity: XML parser error: XML: Failed parsing document. [hostname "www.mydomain.org"] [uri "/wp-admin/admin-ajax.php"] [unique_id "blablah"]

ModSecurity:  [file "/etc/httpd/modsecurity.d/00_asl_z_antievasion.conf"] [line "36"] [id "330791"] [msg "Failed to parse request body.  This may be an impedence mismatch attack, a broken application or a broken connection.  This is not a false positive.  Check your application or client for errors."] [data "XML parser error: XML: Failed parsing document."] [severity "CRITICAL"] Access denied with code 403 (phase 2). Match of "eq 0" against "REQBODY_ERROR" required. [hostname "www.mydomain.org"] [uri "/wp-admin/admin-ajax.php"] [unique_id "blablah"]

Jetpack is 1.7 WP is 3.4.1 Apache 2.2.15 PHP fCGId 5.3.3

Any ideas? The WP forum has been unresponsive so far. I've sent an email to JetPack support.

share|improve this question

closed as off-topic by Mark Kaplun, Pieter Goosen, Johannes Pille, birgire, ialocin Oct 5 at 19:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Your question should be specific to WordPress. Generic PHP/JS/HTML/CSS questions might be better asked at Stack Overflow or another appropriate site of the Stack Exchange network. Third party plugins and themes are off topic." – Mark Kaplun, Pieter Goosen, Johannes Pille, birgire, ialocin
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Given that it doesn't even happen in all cases for you, it's unlikely anyone would be able to accurately reproduce this to answer. Try contacting Jetpack support. –  Rarst Aug 31 '12 at 13:04
    
I did already. It happens almost everytime I click UPDATE, but the exact condition I haven't been able to isolate yet. –  Gaia Aug 31 '12 at 14:07
    
Have you tried disabling mod_security specifically for calls to /wp-admin/admin-ajax.php ? That might help narrow down the problem. –  Otto Aug 31 '12 at 17:17
    
Hello Otto. If I do that then the problem will go away. But I dont think modsec is to blame here... –  Gaia Sep 1 '12 at 12:34

1 Answer 1

up vote 0 down vote accepted

Jetpack support kindly replied:

This could be an issue with the After the Deadline module. When you update a post, WordPress makes a call to the service (service.afterthedeadline.com) to spellcheck your content, and it seems an error occurs during the connection.

Could you try deactivating the Spelling and Grammar module

Disabling it DID fix the problem. It seems that the module does not correctly handle its job when an updated post/page content is empty. The modsec rules are not to blame (Thank you @Otto).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.