Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've built a test site for a client using a theme purchased from Template Monster. I can't seem to find out why the link is broken on this page. and the Template Monster support has extremely poor.

http://trustlabor.com/riverstonesalonspa/portfolio/

I renamed the stock theme "Portfolio" page to "Staff Bios" If I change the page permalink to: http://trustlabor.com/riverstonesalonspa/staffbios/ to match the new name of the page it is a broken link. It's still looking for the stock theme subdomain "portfolio."

Furthermore the page navigation below the thumbnail photos is also broken. If you try to navigate to from Page 1 to Page 2 of the staff photos you get a 404 error message.

share|improve this question

2 Answers 2

Your URL base is http://trustlabor.com/riverstonesalonspa/

You see one page in the URL http://trustlabor.com/riverstonesalonspa/portfolio/ because there is a page or a post with the link "/portfolio". You have to change the permalink in this page, from "portfolio" to "staffbios".

share|improve this answer
    
When I change the permalink to the new designation/name "Staff Bios" I then get a 404 error? I also get a 404 error if I try to click the thumbnail navigation to page 2 further down on the same page? –  Andy Sep 4 '12 at 19:26

It seems like your rewrite rules are messed up. Maybe you should try to flush them and see if it works...

Put flush_rewrite_rules( true ); somewhere in your functions.php

Don't forget to delete that line afterwards, as you don't want to flush your rewrite rules on every pageload.

share|improve this answer
    
You can easily flush the rewrite rules by simply visiting the Permalinks setting page in the WP Admin (Settings -> Permalinks). Just visiting the Permalinks settings page is enough. You don't need to make any changes or update the settings. –  kingkool68 Aug 4 '13 at 1:36
    
You can easily flush the rewrite rules by simply visiting the Permalinks setting page in the WP Admin (Settings -> Permalinks). Just visiting the Permalinks settings page is enough. You don't need to make any changes or update the settings. –  kingkool68 Aug 4 '13 at 1:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.