WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using a theme with custom taxonomies. I want to use corresponding archives. If I try the template out on one network it works, and on another the permalink will take me to 404. The only difference between the two networks that I know of is that the one that doesn't has domain mapping, courtesy of this plugin.

Ideas for how to fix it?

(Just for the sake of it, here is how I generate the archive links: )

<?php foreach( get_terms('region') as $region ): ?>
    <a href="<?php echo get_term_link($region); ?>"><?php echo $region->name; ?></a>
<?php endforeach; ?>
share|improve this question
    
Have you visited the Settings > Permalinks page? Visiting that page will flush and recreate the rewrite rules, and that may help... – mltsy Aug 28 '12 at 21:46
    
Also, can you describe the "code" you're trying out that's working on one network, but not the other? And give more information about the permalinks that you're trying to use? – mltsy Aug 28 '12 at 21:48
    
By "code" I mean the template I wrote, the only relevant part of which is how I generate the permalinks. I now include that in my post. Yes, I tried visiting that page and also updating the permalink settings, but it did not help. – user5028 Aug 28 '12 at 22:09
    
OK, after a night I visited the permalink page again and things started working. Why on earth this it did not do it the first time I visited that page and even clicked save to try to update the permalink structure I don't know. But there was the problem. – user5028 Aug 29 '12 at 6:34

It's not necessarily a fix, but you should be able to use the Rewrite Analyzer plugin to help you understand how WP is rewriting your links.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.