Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I get these warnings after getting live with my wordpress site from local to server.

Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'bones_register_sidebars' not found or invalid function name in /is/htdocs/wp1108989_5IDG6XP7VR/www/cgi-bin/website/wp-includes/plugin.php on line 403

Warning: Cannot modify header information - headers already sent by (output started at /is/htdocs/wp1108989_5IDG6XP7VR/www/cgi-bin/website/wp-includes/plugin.php:403) in /is/htdocs/wp1108989_5IDG6XP7VR/www/cgi-bin/website/wp-includes/pluggable.php on line 881

hoster is hosteurope. any one any ideas how to fix it?

share|improve this question
    
Just curious, where are you hosting your site? I don't mean the provider/company - I mean what's the URL to where you have your files for your entire website/Wordpress install? From the above, it looks as if you're in the /cgi-bin directory? Is that so? –  thatguycraig Aug 28 '12 at 13:09
    
We can't investigate any further without seeing the relevant code ( we're not psychic =p ) –  Tom J Nowell Aug 28 '12 at 13:23
    
See my answer for the bit of code we would need, I've also edited your question to use the code formatting –  Tom J Nowell Aug 28 '12 at 13:35
add comment

1 Answer

up vote 0 down vote accepted

These are warnings, not errors ( edited original question to reflect this ).

You have two options:

  • The easy way - Turn off displaying errors and warnings, log them to a file instead
  • The proper way - Fix the warnings, and log them to a file instead of outputting

If you need help fixing the warnings, post your code I'll update my answer with an explanation of what happened and how to fix them. Specifically, the code in your theme/plugins that adds bones_register_sidebars which is being complained about by PHP

share|improve this answer
    
the bones comes from the theme i think. i used this on: themble.com/bones. otherwise which code do you need? –  max Aug 28 '12 at 13:44
    
Change line 43 of /library/bones.php to add_action( 'widgets_init', 'bones_register_sidebars',1,0 ); –  Tom J Nowell Aug 28 '12 at 13:50
    
it does not work. but if i delete this line of code it works. why is that??!! THANKS BY THE WAY –  max Aug 28 '12 at 13:59
    
try 0,1 ( removing that line will break/remove features ). Also change your error log to output to a file, not the screen else you'll end up with more of these issues when you install more plugins! –  Tom J Nowell Aug 28 '12 at 14:03
    
perfect!!! 0,1 is working. can u shortly explain me what this line does? (the 0,1) thanks!! –  max Aug 28 '12 at 14:15
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.