Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When I'm logged out, everything works fine. When I'm logged in, I'm unable to visit the front-end of my site.

My main page is actually located in a sub-folder of my multisite installation: http://beta.eamann.com/mindshare/. I'm mapping a domain to this installation: http://mindsharestrategy.com/. When I'm logged in, the front-end of my site keeps bouncing back and forth between these two domains. I can still get to the admin side just fine ... but not the front-end.

If I log out, I can view the front-end of things just fine.

I'm using the development version of the plug-in, as I was instructed to do by several conversations with the developers. Ideas?

I should also note that the other sites on this network are not having this issue. They are working properly:

There is no infinite redirect loop here. What can I check to fix the problem?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

this is not a full answer but probably of use to gain more information about your problem. I guess it's related to cookies but that is really a guess only.

To find out more I suggest a combination of two tools: One Firefox and a wordpress Add-On.

No Redirect Toolpress Strict Edition (Firefox Add-On)

On Toolpress in the tools folder, you can find a Firefox Add-On that is tracking every redirect and can prevent automatic redirection on those. It's called NoRedirect 1.2.4 Toolpress Strict Edition (Firefox Add-On).

Install it, restart Firefox. Then go to Menu: Tools -> NoRedirect which opens the configuration dialog. Enter a URL pattern like ^http://.* and *un*check the Allow checkbox:

NoRedirct settings dialog

You will now get a notification prior to any redirect:

NoRedirect notification example

You can click the link in the grey area. The website you see is the redirect body which is generated (here by stackexchange).

Wordpress by default does not return and HTTP Body for redirects which is getting the HTTP specs wrong as HTTP clients do not need to redirect automatically.

Better HTTP Redirects (Wordpress Plugin)

Next to that grab my Better HTTP Redirects Plugin. It deals with the wordpress core defect and returns a HTTP body for each redirect. There is a hook available called redirect_hypertext in which you can hook into (or just hack this plugin which is must-use compatible as well) and output the backtrace that caused the redirect (hint: xdebug).

Power of the two:

The firefox plugin will ensure that you're not getting redirected without confirmation and the wordpress plugin will taking care to display debug information. This hooktracer tool (SJ Hook Profiler) might be of use as well but I have not used it so far.

share|improve this answer
    
@hakre OK, I've installed both, and it's showing me something that might be useful. When I try to navigate to the root URL while logged in, it automatically redirects to the same url with ?action=login&dm=5ed67...&k=0decf...&t=11591... appended to the end. I assume this is something to do with keeping me logged in, but that seems to be where I get hung up and stuck in the redirect loop. –  EAMann Jan 1 '11 at 23:34
    
@EAMann: When you can trigger this, go into the plugins source and for the part that is generating the HTML response, print the backtrace and die(). Then you can find out which code triggers that. You might want to check for some "secret" like $_GET['debug'] === '82l3jkhns'; before so it's visible to you only. –  hakre Jan 2 '11 at 11:54
    
After some digging, I found out that the culprit is the WordPress SEO plug-in by Joost de Valk. Currently contacting the author to hunt down a fix. Thanks for the assist! –  EAMann Jan 4 '11 at 14:58
    
@EAMann: I knew that I recorgnized the params somehow but was unsure from where. Thanks for keeping me updated and good to read that it helped to track things down. –  hakre Jan 4 '11 at 21:30
1  
Actually, the params were added by the MU Domain Mapping plug-in's "remote login" feature. That's how it keeps you authenticated to the network when you go from one site to another. But the SEO plug-in was attempting to convert "ugly" links (query strings) to pretty permalinks and removing the params. I had to add "action," "dm," "k," and "t" to the list of ignored params in the SEO's permalink settings, and now things are working fantastically! Full write-up to follow this week on my blog ... –  EAMann Jan 4 '11 at 21:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.