Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm trying to set up a local WordPress installation using WordPress Skeleton, so that I can eventually use WP Stack.

I've created a local folder called vcip.com and the local hosts rules to resolve kdev.vcip.com to that location. I went to the WordPress Skeleton GitHub page and downloaded the zip file of the repo. I unpacked the files into my vcip.com folder.

I then installed the Git submodule for the wp folder.

I set up a local database and user, and added the details to the local-config-sample.php file, and then changed that file to local-config.php. I also added the salts in wp-config.

When I visit kdev.vcip.com I get redirected to http://kdev.vcip.com/wp-admin/install.php (local url) and get the message "This webpage has a redirect loop".

Have I missed something in the set up? Are there any more variables to configure? Do I need to remove any files from the wp folder?

Thanks in advance for your help.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

OK, it was a noob mistake, as predicted!

I had to go to kdev.vcip.com/wp/ for the installer to run. Once I did that I went to the Settings page and changed my WordPress address to http://kdev.vcip.com/wp and my Site Address to http://kdev.vcip.com.

share|improve this answer
    
Ok .. you can tick your own answer so that others know you accepted it :) –  Damien Aug 15 '12 at 15:27
    
I need to wait 2 days to do that. –  kdev Aug 15 '12 at 19:30
    
Thanks for sharing how you fixed it. –  Pothi Aug 16 '12 at 10:50
add comment

Hej, thanks for leaving this here! If you want to automate your setup with skeleton so that it doesn't require user interaction, all you need is the right SQL data.

Get the SQL dump from a fresh wordpress install and prepare it like this:

  1. Replace the table names with your chosen prefix ( wp_ -> project_ )
  2. Replace 'siteurl', 'http://domain' with http://project.local/wp
  3. Replace 'home', 'http://domain' with http://project.local

Insert into your database and you're ready to go. That's it. Hope it helps someone.

---

Note: There are 3 occurences of wp_ that should not be replaced: wp_inactive_widgets, _wp_page_template and dismissed_wp_pointers

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.