Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

i just transferred my website from shared server to VPS, but then it is not starting, when i inquired with the VPS technical support then they emailed me something this, which i am not understanding:- email

Your site "www.onlinemba.co.in" has been migrated from your previous host and we are now getting a blank page while accessing the database dependant php files. There seems to be an issue with the database codings as all other php files are accessing fine and there is also no problem with the database connectivity. You can check for the same by accessing the site preview URL "http://38.100.101.228/info.php".

Your Kloxo panel details are

URL : XXXXX User : XXXXXX pass : XXXXX

Server root access detail are as follows

IP : 38.100.101.228 User : XXXXXXX Pass : XXXXXXX

Kindly check your database once with your database developers with the details given above and let us know for further help.

what should i do?

ok well i did some changes for this in wp-config.php, but after that the admin guys from hosting are saying me this:

Virtual host entry for the IP is pointing to different folder ( which doesn't have any contents ), hence you have received the default page. I have pointed in to the correct folder "onlinemb". You can view the blank page, please check and resolve it.

i edited the database MySql hostname from local host, to the IP-38.100.101.228 but then he changed again to local host, and again the blank page came, what to do now?

share|improve this question
    
I think you should really sort this out with hosting support. If you don't understand their instructions tell them that and ask to explain more clearly or in more detailed way (support is their job after all). –  Rarst Jan 3 '11 at 11:07
    
they are totally blank with this problem, they say to download the wordpress from the ftp and check it in local host –  ntechi Jan 3 '11 at 11:39
    
i made it work, i renamed the plugins folder name to plugin_temp, and website started, there is a problem in some of the plugins, thanks i cracked it out myself –  ntechi Jan 3 '11 at 13:00

3 Answers 3

up vote 1 down vote accepted

I believe Rarst is right. It sounds like you need to configure the wp-config.php file for the new database. Just go to the cpanel or other control panel of your hosting service, and use the address they use for the host address. If the database is on the same server as the web site, localhost is used.

I am not sure how you moved you website. I assume that it is a WordPress site, and it is not difficult to move. When I did this, I made a new installation of WordPress on the new hosting service. This included installing WordPress with a new database.

Then, I went to the old site WordPress dashboard, found the Export menu, and saved the resulting XML file. This file contains all the database info for your site.

At the new site, I simply went to the new site dashboard Import menu and imported the file from the old site. The new database system then had the correct data from the old site. There were a few issues on the new site, mainly dealing with cosmetic things.

As a matter of fact we should all keep a current backup of our WordPress database, and there is a plugin for that.

share|improve this answer

Had you configured database settings in wp-config.php for the new server?

Hosting provider says your site has issues accessing database. Assuming they confirmed database is working as expected it leaves site configuration itself.

share|improve this answer

In the wp-config.php file, try replacing the (localhost) with the IP address you shared above

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.