Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I currently have Windows 7 , 64 bit on which I am running an IIS on localhost:80 and I installed XAMPP on localhost:8080. I have 15 individual wordpress sites but now i need a subdomain multisite wordpress.

I created wp.dev:8080 in the hosts file for multisite, and correctly amended the apache virtual file. All worked until I added the define('WP_ALLOW_MULTISITE', true); to the config file. When I clicked on the new Network menu option in wordpress, I got an error:

ERROR: You cannot install a network of sites with your server address. You cannot use port numbers such as :8080.

Now here is the problem. localhost is mapped to 127.0.0.1 on port 80 for IIS. And Apache is taking all of localhost:8080. can I somehow split the localhost:80 traffic by assigning wp.dev to be the only :80 to go to Apache and the remainder to continue going to IIS. How would I define that since in Apache I already have *:8080 defined? Please help, my files are below:

Hosts file on c/windows/system32/drivers/etc/hosts this is root of iis if i dont specify port (:80) and if i specify port (:8080) go to xampp 127.0.0.1 localhost these below are the :8080 individual wordpress on xampp 127.0.0.1 sb.localhost tw.localhost ups.localhost vet.localhost box.localhost ea.localhost multisite below 127.0.0.1 wp.dev

This is my Apache config file in D:\xampp\apache\conf\extra\httpd-vhosts.conf

NameVirtualHost *:8080

DocumentRoot "D:/xampp/htdocs" ServerName localhost

This is a working wordpress normal blog

DocumentRoot "D:/xampp/htdocs/ki/abce/wordpress" ServerName abce.localhost Options Indexes FollowSymLinks ExecCGI Includes Order allow,deny Allow from all

This below is how network subdomain blog that would work if not for 8080 problem

DocumentRoot "D:/xampp/htdocs/alllive/wordpress" ServerAlias *.wp.dev ServerName wp.dev Options Indexes FollowSymLinks ExecCGI Includes Order allow,deny Allow from all

Thank you in Advance!

share|improve this question
    
I run IIS and Apache and I do the opposite, I ran Apache on localhost:80 and IIS on :8080. You might need to change your windows host file, I think this is a know issue. –  Wyck Aug 12 '12 at 5:40
    
@Wyck, Thanks. I am trying to do just that now.. huge headache and waste of time... You should post the answer, I will wait and give you points in a day or two if nothing better comes along, cuz i searched for hours, and nothing. –  NickNo Aug 12 '12 at 7:50
1  
I think you'd have a much better chance of an answer on ServerFault - requesting a move :) –  TheDeadMedic Aug 12 '12 at 9:04
    
Just for starters ... Setup of WordPress multisite as localhost needs to be sub-directory install. And you will need to move to port 80 for Apache. This might help you ... wordpress.org/support/topic/… and @AndreaR or Ipstenu on the Multsite Forum are brilliant –  Damien Aug 12 '12 at 9:23
    
maybe your help is this answer –  bueltge Sep 3 '12 at 14:28
show 1 more comment

1 Answer

Ok, I gave up and moved to port 80, though i think what @Boultge suggest (the link) would have probably done it, but I read it too late.

Here are the files tho that are letting me run XAMPP WordPress MU sub-domain Multisite on localhost as wp.dev with 20 additional WordPress individual sites. I shortened it because i have 8 sites per line and both my wpmu and regular wordpress sites all look the same, i just have to be careful not to pick a name for a new multisite domain that i am already using for the regular wordpress

Here is the c:/windows/system32/drivers/etc/hosts

127.0.0.1 localhost

127.0.0.1 wp.dev

127.0.0.1 somename.wp.dev someothername.wp.dev wpmu1.wp.dev wpmu2.wp.dev wpmu3.wp.dev

In httpd.conf file located in xampp/apache/conf I have (all else left as is):

Listen 80 # line 47

ServerName localhost:80 # line 184

In httpd-vhosts.conf in xampp/apache/conf/extra:

DocumentRoot "D:/xampp/htdocs" ServerName localhost

DocumentRoot "D:/xampp/htdocs/regular-wordpress-1/wordpress" ServerName

somename.wp.dev

"D:/xampp/htdocs/regular-wordpress-1/wordpress"> Options Indexes

FollowSymLinks ExecCGI Includes Order allow,deny Allow from all

DocumentRoot "D:/xampp/htdocs/regular-wordpress-2/wordpress"

ServerName someothername.wp.dev

Options Indexes FollowSymLinks ExecCGI Includes

Order allow,deny

Allow from all

The rest of them above are all the same, each one a completely independent wordpress install.
At the very end of httpd-vhosts.conf comes multisite domains below:

DocumentRoot "D:/xampp/htdocs/wpmu-home/wordpress"

ServerAlias wpmu1.wp.dev

ServerAlias wpmu2.wp.dev

ServerAlias wpmu3.wp.dev

ServerName wp.dev

Options Indexes FollowSymLinks ExecCGI Includes

Order allow,deny

Allow from all

No other directive is activated besides what's here in the httpd-vhosts. With this sub domain wordpress multisite on xampp works fine though on port 80.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.