Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a project on Wordpress. I would like add an article. In admin panel I click on Post, then Categories and add a new category called article.

Next I add a new post and edit title, body and finally check the category called article. Now i have:

Permalink: http://mypage.org/article/test

On site also is this link, but if I open this url I have:

This entry was posted in article. Bookmark the permalink. Follow any comments here with the RSS feed for this post. Post a comment or leave a trackback: Trackback URL. Edit

But in this url I don't have my article. Why? In index page I have it, but if I open an article I have this error.

What can I do?

share|improve this question

migrated from stackoverflow.com Aug 9 '12 at 12:34

This question came from our site for professional and enthusiast programmers.

    
Did you click on the blue button «Publish»? –  nalply Aug 8 '12 at 19:18
    
yes, of course. All articles are on page, but links are wrong –  Tom Leading Aug 8 '12 at 19:29

1 Answer 1

Go to Settings, then General Settings, then enter the correct url for your Wordpress Address (URL). Perhaps you need to change your Site Address too.

Source: The Wordpress Codex: http://codex.wordpress.org/Settings_General_Screen

If this isn't the case, but the category links are bad, edit the category slug. Go to Posts, then Categories, select article and edit the slug. Perhaps you had a different slug beforehand.

It's difficult to help you. It's a game of guessing. I will stop here.

share|improve this answer
    
i have there correct url. Others links on pare are good, only in articles is bad. –  Tom Leading Aug 8 '12 at 19:47
    
Ah, I see. It's a category problem, isn't it? –  nalply Aug 8 '12 at 19:54
    
yes, this is problem with links to post in categories –  Tom Leading Aug 8 '12 at 19:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.