Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm getting this error repeatedly in my error.log:

[Wed Dec 29 13:46:37 2010] [error] [mod_pagespeed 0.9.11.5-293] http://marcandkatie.co.za/index.php:1: Reached end of document without finding <body>

And I believe it's caused my site todo this when I go to the admin:

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 4666733 bytes) in /home/marc_and_katie/marcandkatie.co.za/wp-includes/wp-db.php on line 849

Any thoughts?

share|improve this question
    
Please specify the wordpress version you use on that host. I smell you're hitting a memory leak in wp-db.php. This can be caused by data in the database. Are you able to get a backtrace of the error logged? –  hakre Dec 30 '10 at 13:52
add comment

4 Answers

So I started going thru plugins and my Mailchimp plugin seemed to be the issue as I can tell so far. I'm no longer getting any errors.

share|improve this answer
    
Please mark your answer as the solution. –  hakre Feb 6 '11 at 16:45
add comment

this error is caused because of wp-cache plugin, not sure but clear your cache from, the error might go

share|improve this answer
    
The problem is I can't even clear the sites cache because I get that second error when I try to go to my admin. So I don't have access to the plugin settings to clear the cache. –  Marc Dec 30 '10 at 6:07
    
i think you need to give 777 permission to your wp-content folder, or try to copy paste db.php from plugins/wp-cache/wp-content directory from cpanel –  ntechi Dec 30 '10 at 6:13
    
to the folder and the files and folders within it? or just that folder? EDIT: I'm using wp-super-cache... does that make any difference? also what file am i copying cause the directory you mentioned doesn't exist. –  Marc Dec 30 '10 at 6:19
    
see the same error i was getting but i was using w3-total cache plugin, these both plugins are almost same, i solved this error just by copy pasting files, i ll xplain you navigate to wp-content/plugin/wp-super-cache/wp-content/ here you ll find db.php file, just copy that and paste it into wordpress/wp-content see if this works :) –  ntechi Dec 30 '10 at 6:29
    
there wasn't a wp-content folder inside of the wp-super-cache folder so there's no db.php file to copy. right now i just renamed the plugin so it wouldn't be active and i can login now. any other thoughts? –  Marc Dec 30 '10 at 6:33
show 10 more comments

It seems like something in your WordPress installation exhausts available resources.

It is impossible to even guess from this much information, first step would be to disable all plugins and troubleshoot from there. Since you don't have access to admin see How to deactivate all plugins when not able to access the administrative menus?

share|improve this answer
add comment

Just an FYI the error you're getting from mod_pagespeed is AFTER the php error.

Delete the plugin completely, and then re-install the w3-total-cache plugin, and then run a compatibility check.. see if it says anything about permissions or ownership.

share|improve this answer
    
nope just this: Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 8729995 bytes) in /home/marc_and_katie/marcandkatie.co.za/wp-includes/wp-db.php on line 787 –  Marc Dec 30 '10 at 7:02
    
this happens even when you're in the admin screens? or just the home page? and is this 3.0.4 ? –  Vid Luther Dec 30 '10 at 7:10
    
Now it's happening nearly everywhere. Yes, it's 3.0.4. This is just getting annoying now. –  Marc Dec 31 '10 at 3:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.