Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have 20+ WP sites installed for clients on different web hotels. All WP-installs are updated to run latest versions of everything.

On some of my sites, the update- and install screens work as expected when I update or install a theme/plugin, the page updates and ends displaying the sucess/finished message.

On some of my sites however, these screens always just show the first line like "downloading package" (or something like that, you get the point), but then they never progress. It seems however that everything always gets installed updated as it should. Even when I do a batch update of more plugins.

It seems to be a hosting issue, as it's the same for all sites on the same host.

Does anyone have a hint at what it might be in the server configuration that is preventing these screens from updating on the progress?

share|improve this question
add comment

3 Answers

Make sure the folders permission (CHMOD) are right. See - Wordpress Specific permissions modes

It could also maybe be a timeout problem on the server?

share|improve this answer
    
folder permission seem ok, the installation or upgrade also works fine. I'd expect them to fail if the folder permissions was the issue. Timeout is not the problem. I have other processed that take much longer that finish fine. timeout is 120 sec, and the update screens just dies of immediately after the first line is shown. It must have something to do with the ajax requests being dropped. –  mikkelbreum Aug 8 '12 at 20:32
add comment
  • Deactivate all plugins
  • Switch back to the default theme

… try again.

  • Delete the ~/wp-content/upgrades folder.

… try again.

  • Check your .htaccess settings.

Things to inspect:

  • What server is it? Windows/Linux/...?
  • Check phpinfo() for differences.
  • ...
share|improve this answer
add comment

I think I found a way to get it work. If it is your own server you can try to change the php-mode from Fast-CGI to ModPHP/SuPHP - Those both modes work for me in this case. I wasn't able to activate it for FastCGI tho. If someone does know an answer to this, please let me know.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.