WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm completely stumped as to how I can update my account configuration in Windows Live Writer to enable Page Capability so I can select "Create a new page" at the menu option. That option is currently grayed out for me.

I've been able to edit pages before, but I recently updated my computer and had to reinstall software so I'm not sure what could have changed in that process. My Live Writer seems to be connected properly to my WordPress blog, but I can only create or edit "posts" at this juncture.

I've googled my problem and searched all over this site but there doesn't seem to be a fix for me that I can find. Please help me enable pages!

Thank you!

share|improve this question

Obviously as you have realised, something has changed since you updated your computer. May I suggest that you first of all, delete that Wordpress blog from Writer, then attempt to add it again. If that doesn't work, I would uninstall Writer and then re-install it, all worth a try. If its the 2011 version, you could also try to repair Writer (by going to Programs, uninstall but choosing 'repair' instead. As you so rightly state, you should be able to also access your Wordpress pages to edit etc from inside Writer as well as your posts.

share|improve this answer
Thanks Technogran. I tried your tip and I'm still having the same issue. I am continuing to trouble-shoot but thank you for your suggestion. – Berni Aug 6 '12 at 19:49
OK, a friend helped me find a fix. From WLW, in the account information settings within the selected blog, I ended up changing the blog service provider from "WordPress" to "WordPress 2.2+" and oddly enough that did the trick. Now I'm able to access the "create a new page" button. – Berni Aug 6 '12 at 20:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.