Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

For a couple of days i use the wp super cache plugin and it works quite well. I also updated to the latest version of wordpress which is currently Wordpress 3.4.1.

Whenever i update something in the posts. I can browse the front page of my blog but on the single page i get a too many redirects error. When i go to settings > permalinks and update the permalinks without any changes the blog is doing fine.

Is there some magic setting that avoid this behavior?

share|improve this question

put on hold as off-topic by Pieter Goosen, Mark Kaplun, birgire, toscho Oct 17 at 19:40

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
Do you have to update your permalinks every time you update a post to avoid this behavior? What's your permalink structure? Do you have any other plugins active? –  Matthew Boynes Aug 8 '12 at 12:06
    
What browser are you using? next - do you experience the same problem in other browsers. –  woony Aug 8 '12 at 12:42
    
also post your .htaccess, when you updated a post. and your .htaccess when resetting it. There will probably be a difference cause by the plugin. –  woony Aug 8 '12 at 12:53
    
Do you have "Extra homepage checks" enabled? –  Zach Aug 10 '12 at 20:10
    
Why not switch to W3 Total Cache? Does that have the same error? –  Syed Balkhi Aug 12 '12 at 17:57

1 Answer 1

It's a cache problem. See if the cache directory is writable (it should be 755), try to empty it and try again.

Another cause might be the combination of CURL extension and enabled open_basedir. Check with your host.

Another solution might be to try the "Permalink Fix & Disable Canonical Redirects Pack" plugin - http://wordpress.org/extend/plugins/permalink-fix-disable-canonical-redirects-pack/

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.