Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I installed theCartPress plugin and it created tcp_product_category taxonomy for tcp_product post type. I created a page with custom template to list all the product categories.

I can use single-tcp_product.php, but taxonomy-tcp_product_category.php doesn't work. I tried removing tcp_ (it's rewritten like that), tried everything from template hierarchy. I installed "Reaveal template" plugin and when I visit

http://palivonas.lt/test/islosaitis/product_category/spinteles/ 

it shows "archive.php". I tried changing code, nothing changes there. I emptied archive.php, category.php, index.php, page.php and nothing changed in that link, still shows "Category Archives: spintelės" title and list of products. Any ideas?

Don't mind any layout issues, I'm just trying to make it work, then design.


I've been trying to make this work for a few hours now and I give up, I need help.

share|improve this question
    
If this is plugin-specific, you're probably going to get better support on the plugin's support site. –  mrwweb Jul 31 '12 at 19:11
    
No, it's not. Plugin is for cart, buying and other stuff. This is just custom post types. I've ran into this problem before just using custom post types without any plugins, but left it. –  Andrius Jul 31 '12 at 19:35
    
@AndriusPalivonas Just downloaded the plugin. It implements it's own template hierarchy for cart-related taxonomies. There even seems to be an options area for configuring them. –  TheDeadMedic Jul 31 '12 at 23:35
    
@TheDeadMedic it's old question, but I'll just let you know, that somewhy that options area didn't change anything for me. –  Andrius Aug 19 '12 at 16:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.