Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I can't write comments to new articles (no add comment link available). I use Wordpress 3.4.

I checked the discussion properties and they are set to

  • allow guests to comment articles
  • none of the other (relevant) options are checked

I have the feeling that comments aren't available since I installed some plugins. But I tried deactivating some with no success in activating comments again.

Suggestions?

share|improve this question
    
Disable all plugins and switch to TwentyEleven. Does it still happen? –  toscho Jul 29 '12 at 20:37
    
I did that and in the articles is a text now: comments are closed. –  juergen d Jul 29 '12 at 20:40
    
Write a new post, enable the discussion meta box and make sure comments are enabled. Still no change on the front-end? –  toscho Jul 29 '12 at 20:43
1  
You have to activate the discussion meta box. In a German WP it looks like this: i.imgur.com/sktNd.png –  toscho Jul 29 '12 at 20:50
1  
That are the Dashboard screen options, we are talking about the new post page wp-admin/post-new.php –  toscho Jul 29 '12 at 20:56

2 Answers 2

up vote 3 down vote accepted

Comments might have been closed once. If you change this option later globally it doesn’t affect existing posts when comments were turned off per post. To test if comments really work create a new post and enable the discussion meta box on that screen:

enter image description here

If you can comment while all plugins are disabled and the theme is TwentyEleven (default) – then everything works as expected.

share|improve this answer

@toscho is right, you might have been disabled the comments for individual posts.

However if you want to enable comments for all your old posts you accidentally disabled, you can use following MySQL query to do it once instead editing each post manually.

UPDATE wp_posts SET comment_status = 'open' WHERE post_type = 'post'

Notice - This will enable comments for all your posts not the pages.

Warning - Don't forget to backup your database before using this query.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.