Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am using WordPress 3.4.1 on Ubuntu 12.04 using Apache and PHP 5.3.X

When I login to the dashboard and add a new post. Then try uploading an image to set as a featured image, I get a red box with a message "HTTP Error".

I have read about people saying to not use the flash uploader and just use the browser uploader, but when I try that, I just get a 500 Internal Server Error.

I have tried adding AddType x-mapp-php5 .php at the top of my .htaccess file, with no luck in change.

Disabling ALL plugins had no effect. I tried a fresh install. No luck.

WordPress 3.4.1 Media Upload HTTP Error

share|improve this question
add comment

4 Answers

up vote 2 down vote accepted

After troubleshooting with @Wyck in chat, we have narrowed to the underlying issue.

The issue was related to my server configuration not having the proper amount of memory allocated to Apache/PHP.

If anyone has this same problem, please try verifying that you have enough (64MB+) server memory allocated to Apache/PHP in your server configuration settings. You can also add this to your wp-config.php file: define('WP_MEMORY_LIMIT', '64MB');

If the above solution does not work, read this article (Image/Media Uploader problems?) for further trouble shooting.

try adding one by one or all of the following .htaccess tweaks to the .htaccess file in the root directory of your WordPress installation.

Seriously, try one of each of the solutions below so you know which one did the trick. Don't just paste them all in your .htaccess file immediately.

Try this line:

AddType x-mapp-php5 .php

mod_security might be causing problems. Disable it to see if that is the problem. To do this, make an .htaccess file in your wp-admin directory. Add this to it:

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

If you're using Access Control based on Authentication on your Webserver (often known as htpasswd, Basic Authentiaction, password protected directory or similar), WordPress is not able to handle it for Flash Uploader, Cron and XMLRPC. Related files need to be excluded to work. Keep in mind that this might break your security considerations.

# Exclude the file upload and WP CRON scripts from authentication
<FilesMatch "(async-upload\.php|wp-cron\.php|xmlrpc\.php)$">
    Satisfy Any
    Order allow,deny
    Allow from all
    Deny from none
</FilesMatch>

One final note: some have said that if using a lesser version of PHP 5.3.X you can try disabling PHP Safe Mode.

If you are running WordPress multi-site and are receiving HTTP errors or Internal Server errors, related to image uploading, please read Uploading Images to Multi-Site Causes Failure to HTTP Error for other possible trouble shooting ideas and solutions.

share|improve this answer
    
Whats wrong with your server configuration? Not enough ram or ??? Can you explain please? Just wondering .... –  Damien Jul 26 '12 at 22:02
    
@Damien The issue was related to my server configuration not having the proper amount of memory (AKA - RAM) allocated to Apache/PHP. –  Michael Ecklund Jul 26 '12 at 22:13
    
ok ... good to know ... did you read that WP tries to allocate up to 256MB of ram so this define('WP_MEMORY_LIMIT', '64MB');should be larger if possible. –  Damien Jul 26 '12 at 22:35
add comment

I have resolved this issue by changing my owner from root to apache as below.

chown -R apache:apache /var/www/html/mydomain

and then i have change the permission of the wp-content/uploads/ 775

after that i have tried to upload image in the media i was successful to upload the image.

share|improve this answer
add comment

I was using WordPress 3.4.1 version after upgrading 3.4.2 version i was facing the HTTP Error problem when tried to up load image and activating the plugin, editing the .htaccess file and so on didnt worked for me, problem sucked my 10 hours, this is a bug for 3.4.2 version, i uploaded the older version script 3.4.1 then it worked for me.

share|improve this answer
    
Is there a trac ticket for this, or are you willing to submit one? –  Brian Fegter Sep 26 '12 at 2:29
add comment

i suggest to update your wp version to latest version 3.7 and make the media uploads folder from media setting in wp and give wp-content and uploads permission 777

that's always works well with me

share|improve this answer
1  
Never set 777 permissions. If there is a registered PUT handler on the server, anybody can write anything into that directory. –  toscho Oct 29 '13 at 10:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.