Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

What may be causing the installation errors I continue to get when trying to auto update anything in Wordpress? I've been manually upgrading everything for quite some time, and I've tried all sorts of permissioning schemes.

Here's a sample error: Installing Theme: Indore 1.0.1 Downloading install package from http://wordpress.org/extend/themes/download/indore.1.0.1.zip

Unpacking the package…

Could not create directory. /public_html

Thanks!

share|improve this question

migrated from webapps.stackexchange.com Dec 25 '10 at 6:22

This question came from our site for power users of web applications.

    
That's not that easy to answer. Do you have any idea of which path /public_html` of the error message is part of? –  hakre Dec 25 '10 at 13:36

2 Answers 2

The Could not create directory. /public_html error message can be related to multiple issues.

Most of them are related to your file-system. This includes the type of filesystem (e.g. NTFS under windows based servers) and the access settings for those. You have not named any in your question, so I assume some linux based host because of popularity and the type of slash.

So you need to first take a look what is going on behind the scenes. A little checklist to be helpful resolving such issues that just came out of my mind (just add feedback if you like):

File System Access Checklist

  1. Locate the full path where you installed your blog to. Note it down as "Installation-Path".
  2. Locate the part of it that is referring to /public_html out of your error message.
  3. Locate that directory in the file system based on "Installation-Path".
  4. Check if it exists.
    • If it does not exist, you have got a path configuration problem. If so, configure wordpress to use a correct path:
      1. Locate your correct path to the blogs installation.
      2. Locate the setting(s) that contain the wrong path.
      3. Correct all wrong setting(s) to the right path.
    • Check if you still get an error message and restart from top if so.
  5. Gain knowledge about which user is executing PHP on your server.
  6. Identify the username and -id. Write both down.
    • If you can not find out about the user, contact your hoster for the information.
  7. Check if the user has enough rights in the filesystem to access the path in questions for the following actions:
    1. Read directories
    2. Create files and directories
    3. Delete files and directories
  8. If any of the three checks under 7. did not work you found a cause of the error message. Your user does not have enough rights on the file-system to perform an auto-update. Please re-configure your file-system that all three work out. Then re-check and continue from top in case you still get an error.
  9. Check that directories created new by that user do have the propper rights set to perform these three actions inside newly created directories as well.
    • If that is not the case you need to reconfigure your file-system and wordpress (hint: FS_CHMOD_DIR).
    • After reconfiguration, re-test and continue from top if you still get an error.
  10. Check the same as in 9. but for files created new by that user.
    • If that is not the case you need to reconfigure your file-system and wordpress (hint: FS_CHMOD_FILE).
    • After reconfiguration, re-test and continue from top if you still get an error.

How to perform the tests? If you don't know how to perform these tests in context of your wordpress installation, please contact technical support for either your host and or wordpress.

Additional stuff you should check are the file-system methods. A helpful thingy to gain more knowledge here is Core Control (Wordpress Plugin), good to know for use is this WordPress Filesystem Abstraction FAQ (DD32 Blogpost).

As I assume it's most probably some configuration issue related to your file-system I assumed that you're using the direct method for file-system-access. If not, the checklist above might help you to enable your server for the direct method which is the preferred one.

share|improve this answer

I think this is due to the ftp user and the webserver user being different.

If you can login through ssh, try selecting "ftps" in the wordpress upgrade dialog. Otherwise, ask your hosting provider to login as root and assign al your files to your ftp user, as it is possible that some are currently assigned to the web server user, giving rise to the error you encounter.

I am also having this problem, and have resigned to upgrading manually...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.