Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

on my development wordpress server (using Desktop Server's "ServerPress"), one my pages has a list of pdfs; each tag has this path: /wp-content/themes/accessgroup/docs/thePDF.pdf.

When I upload my installation to my production server, and I click on one of these links to view a pdf, I get Wordpress's default 404 page. The path to the file did not change, so how is it not seeing them? I've verified that these pdfs have indeed made it to the production server.

Even weirder - I have another page with links of pdfs that link to the very same directory above, and I'm able to view those PDFs (although different than the ones above).

Any ideas?

UPDATE - I added a link to one of the PDFs that did not work to the actual template file for the page of PDFs, and I was able to download and view the pdf in the browser. This is pretty bizarre..same exact link...but if I click on the one added through the wp admin page editor, it doesn't work. If I click on the same one added directly to my template file, it works. What is going on?

share|improve this question
1  
Do the links say the same thing in the status bar when you mouse over them? (Perhaps a weird path issue or something...) –  fdsa Jul 21 '12 at 0:07
1  
Do your PDF file names have spaces or capital characters? It's possible one server is case insensitive and the other is not. –  Brian Fegter Jul 21 '12 at 3:20
    
@BrianFegter Son of a B! Yes, the live server does appear to case sensitive. The pdf was named '2012AFS.pdf', and apparently the live server cares about that. The way I have it in my anchor tag is all lower case for the name of the pdf. Thank you!!!!! I wasted a Friday night pulling my hair out, trying to figure out the problem! –  Mark Bubel Jul 23 '12 at 14:16
    
:) Glad to help out! –  Brian Fegter Jul 23 '12 at 14:53
add comment

1 Answer

up vote 2 down vote accepted

Thanks to @BrianFegter comment, I was able to find and fix the problem. It was just a problem of case-sensitivity. My development environment, http://serverpress.com/products/desktopserver/ , doesn't have a problem with finding the pdf when the file name was caps and the anchor tag link was in lower case. My hosting provider seems to be the problem though, so I just changed all files to lower case and that fixed the problem.

share|improve this answer
    
+1 for finding the solution and answering your own question =] –  Tom J Nowell Jul 23 '12 at 14:40
    
For reference, Windows filesystems are case insensitive, *nix filesystems are case sensitive. hello.png and Hello.png are the same file on Windows, they're 2 different files on OS X/Linux –  Tom J Nowell Jul 23 '12 at 14:41
1  
@TomJNowell OSX is not necessarily case sensitive. Depends on the file system you've chosen. In fact, I'm pretty sure that factory OSX installations use a case insensitive file system, and you have to go out of your way to change it. –  MathSmath Jul 23 '12 at 15:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.