Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

On my mac, I modified virtual host:

<VirtualHost *:80>
  DocumentRoot "/Users/me/Documents/github/gps_cms"
 ServerName gps_cms
 </VirtualHost>

That is so I can type gps_cms in url and invoke the web page on local host.

However, when i type in

http://gps_cms/wp-admin

in address bar, it redirects to my main site:

http://mysite.com/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F

And the content on page is this:

No Update Required

Your WordPress database is already up-to-date!
share|improve this question
    
Have you checked your host file on the computer? –  Jeremy Jared Jul 19 '12 at 19:38
add comment

1 Answer

WordPress will try to redirect you to the canonical URL for the site, as set in the database during the initial install. But you can override it in the wp-config.php file by setting the WP_HOME constant:

http://codex.wordpress.org/Editing_wp-config.php#Blog_address_.28URL.29

If WP is installed in a subdirectory, you might also need to set WP_SITEURL.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.