Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have two Custom Post Types, "event", and "opportunity". They share a custom hierarchal taxonomy, "location". My client had added a handful of terms (United States (parent), then a few States (children)). I decided to save them time by adding the rest of the States via wp_insert_term.

This worked great! Or, so it seemed.

The terms showed up fine for me as an admin.

When logging into a "Contributor" account, I can go and create a new "Opportunity", and all the terms show as expected. When going to create a new "Event", the only terms that show up are the ones that were created by hand. You can add a new term on the spot via "Event" and it shows up just fine in the location manager.

Its as if WordPress is caching the older terms.

Any ideas what might be causing this or where I should look?

Details:

WordPress 3.0.3
Role Scoper 1.3.20

share|improve this question
    
This other questions likely related worked for us: wordpress.stackexchange.com/questions/8357/… –  luison Aug 28 '12 at 9:13
add comment

1 Answer

up vote 1 down vote accepted

There are some bugs related to hierarchical term caching, indeed:

http://core.trac.wordpress.org/ticket/14704

http://core.trac.wordpress.org/ticket/14485

share|improve this answer
    
Any suggestions for clearing the cache? Reviewing the tickets now. –  Jonathan Wold Dec 24 '10 at 14:31
    
Thanks for the references, Scribu. It turned out that it was caching - Its been awhile since I resolved this. Some action of mine with the terms forced it to reset. –  Jonathan Wold May 26 '11 at 15:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.