Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

i have a memory issue while NextgenGallery try to create the thumbnails.

Wp-Version is 3.4.1

Fatal error: Out of memory (allocated 29884416) (tried to allocate 2000 bytes) in /xxx/wp-content/plugins/nextgen-gallery/lib/gd.thumbnail.inc.php on line 179

But my memory is not exceeded: PHP Version : 5.2.17 / 32Bit OS Memory limit : 128 MByte Memory usage : 27.75 MByte

I am getting desperate trying to solve this issue.

Many thanks in advance for any help, Joe

share|improve this question

2 Answers 2

this just means you need to make a small change in your .htaccess or create a php.ini to increase the allocated memory for WordPress.

You and your visitors will see this out of memory error when WordPress is trying to process something (in your case the thumbnails).

Try either of these to fix the problem
1. Create a file in your root /WordPress folder called php.ini , add this line in PHP.ini
memory_limit = 64M;
2. If you don’t have access to PHP.ini try adding this to an .htaccess file:
php_value memory_limit 64M

You can also try increasing it to 128M or 256M

If that doesn't work - contact your web host provider for their preferred method.

share|improve this answer
    
Thanks a lot for your answer. it IS a providerproblem. Changed already ;) –  JSS Aug 19 '12 at 15:35
    
There is some discussion of root causes @ wordpress.org/support/topic/out-of-memory-when-uploading-images –  Michael Paulukonis Sep 4 '12 at 15:26

I'm not sure where you're getting those stats, but I doubt that is showing you the amount of memory being used while processing the images. If you navigate to some memory use screen, you're seeing the amount of memory currently allocated, which is now an entirely different process from when you were uploading images. The fact that Out of memory (allocated 29884416) is already larger than 27.75 MByte points to this.

share|improve this answer
    
Thanks a lot for your informational answer. But why is the upload of all the images working and the gereration of the thumbnail fails? And, is there any chance do lower the allocated memory? Or what would you suggest to solve this issue? –  JSS Jul 17 '12 at 11:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.