Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

So I have this Wordpress blog at ilovetheupperwestside.com. It uses the Aggregate Theme from Elegant Themes.
I moved it from a temporary location to the current URL.

This action broke some things, but thanks to a plugin called "Velvet Blues Update URLs" and a (serialization safe) database search & replace script nearly everything was fixed. One problem seems to still remain.

Media paths that are generated by Wordpress are server directory paths, example from this article:

<div class="thumb"> 

<img src="/home/sear9635/public_html/uwsb/wp-content/uploads/et_temp/morningside-heights-amsterdam-960-166604_200x200.jpg" class='single-thumb'  alt='The Magic of Morningside Heights' width='200px' height='200px' />                     

<span class="overlay"></span>

</div>  
<!-- end .thumb -->

The file in question is a new file which I just uploaded. The thumbnail was generated by Wordpress with the faulty URL. This seems to occur with all media content.

Does anyone have any idea what's going on? Any help would be greatly appreciated.

share|improve this question

migrated from stackoverflow.com Jul 16 '12 at 2:13

This question came from our site for professional and enthusiast programmers.

3 Answers 3

look for wp-app.php and MEDIA_SINGLE_PATH

share|improve this answer
    
wp-app.php seems to be identical Wordpress' current default. Will look into MEDA_SINGLE_PATH, so far no luck. –  Orun Kabir Jul 13 '12 at 20:54

Two ideas:

  1. Go to Settings -> Media and make sure that the media folder is set up properly. Is it set to save to a custom folder - the server path you indicated?

  2. If that's not it, it might be worth attempting the migration again with a tool like BackupBuddy or, if you don't have that, then by simply dumping the old database, dropping all the tables from the new DB and importing it again - then making sure to set the new URL using the wp-config.php file

Then you could use the search/replace plugin to replace only absolute URLs within posts, links and such.

9 times out of 10, that will resolve migration problems right away.

share|improve this answer
up vote 0 down vote accepted

I fixed it by editing "custom_functions.php" within my theme, it was a bug that occurs when updating some Elegant themes.

Instructions here:

http://www.agentwp.com/fix-thumbnails-not-working-in-a-wordpress-theme-from-elegant-themes

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.