WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a website www.mcruiseon.com. I have added .htaccess to get all www.mcruiseon.com to redirect to www.mcruiseon.com/wordpress. But the 'wordpress' still shows up on my html link on browser. Can I hide the fact that the website is hosted under a folder wordpress ?

share|improve this question
up vote 2 down vote accepted

If understood correctly, you'll have to follow this Codex instructions: Using a pre-existing subdirectory install.

If you already have WordPress installed in its own folder (i.e. http://example.com/wordpress) then the steps are as follows:

If that's your case, you'll learn how to make WP work as if it were on the root, even being installed on a folder. If your actual .htaccess only have the redirection you mention, you can delete it, otherwise make a backup so you can merge it with the new one (from WordPress).

share|improve this answer
  1. Remove the custom redirection rule you said you added in your .htaccess file.

  2. In WordPress Dashboard > Settings > General > Site Address (URL) — change the URL to http://www.mcruiseon.com

  3. Read this for more info.

share|improve this answer
Actually, that's what brasofilo said. +1 to him :) – its_me Jul 7 '12 at 5:54
These changes are scary :), I think I'll try it out on my test setup and then production. Thanks guys. Very helpful. – Siddharth Jul 7 '12 at 6:01
Thanks @AahanKrish, I should have left a message pointing your misreading... Cheers, +1+ two! – brasofilo Jul 7 '12 at 15:47
@brasofilo haha! nevermind! :D – its_me Jul 7 '12 at 15:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.