WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My customer's site was working last night. Today nothing displays from the front end. Firebug gives as the contents of the home page. I logged in. The back end looks fine. The most recent post (added yesterday some time) is there. I looked (briefly) at index.php, wp-blogheader.php, wp-config.php. They all look right at first glance. No obvious problem like the file being deleted or contents munged or the like. I looked at the database with phpmyadmin. The obvious options (home, etc.) look ok. The numbers of pages and posts etc. look OK. Which is consistent with the back end looking right.

Running WP 2.9.2 and Semio Reloaded 0.9.2, Version Checker 2.1.5 active. All plugins updated according to version checker.

Does anybody know what might be causing this?

Possible clue based on "what did you do recently?"... I deleted an old (2.8.?) WP install from a different directory/folder. The deleted install was in /news2/. The current one is served from /news/. The databases for both installs were in the same MySQL db. The old deleted one had "wp_" as the table prefix. The current one has "asepco_" as the table prefix. Again, a look at the db using phpmyadmin shows that both sets of data are there, and nothing obvious seems amiss.

Any "did you look at ..." type suggestions would be welcome. I'm a bit stumped right now.


share|improve this question
do this first: wpmu.org/… – onetrickpony Dec 22 '10 at 1:57
Good idea. Will use this in future. Thanks. – xsace Dec 22 '10 at 3:37

Have you tried the default theme? Does that work? Did you change the wp-content folder to something else?

share|improve this answer
Good idea. Switch to default theme fixed the problem. Switching back to original theme retained the fix. I found the answer on Wordpress.org at wordpress.org/support/topic/… – xsace Dec 22 '10 at 3:37
@xsace If that fixed your problem, please select this as "the" answer to your question. – EAMann Dec 23 '10 at 15:44

I know that this is quite an old post, but thought of giving a possible solution, which worked out for me. Go to the root of your wordpress installation and open up index.php and replace following code.




Since, I'm hosting on windows server, ./ resembles filename on current directory in linux environment.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.