Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm running wordpress locally on 127.0.0.1 on mac osx lion. All links work fine. Problem is when I add pages, and set permalinks to the page, and then associate the page with one of my template themes, as shown in this link below:

http://i49.tinypic.com/xdfjfp.jpg

I get this:

Not Found The requested URL /gps-products was not found on this server.

Now I have the same code (including the htaccess file) and same database on two different macs running lion, and it works fine on one but not the other, so I believe the issue is related to the apache configuration.

share|improve this question
    
Close-voted as off-top since this deals specifically with server configuration. This might get more attention at Server Fault or Stack Overflow. –  Brian Fegter Sep 21 '12 at 7:07
add comment

closed as off topic by Brian Fegter, Wyck, kaiser, toscho Sep 22 '12 at 14:45

Questions on WordPress Development Stack Exchange are expected to relate to WordPress within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

This is really an Apache and OS X question and not specifically WordPress, but you may need to edit Apache's httpd.conf file to allow .htaccess files to work on the one Mac.

Go to /etc/apache2/ (That's for 10.6; Lion may be different) with the Finder's Go >> Go to Folder... menu item (or via terminal) and edit httpd.conf and uncomment the instances of AllowOverride All in one or more <Directory ...> blocks. There may be several. Then restart Apache or reboot the Mac.

See http://akrabat.com/php/setting-up-php-mysql-on-os-x-10-7-lion/ for the whole process, including editing httpd.conf

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.