Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a views counter on each post. When it reaches for example 1000, it adds a dot as the thousand separator, the result is 1.000. This is odd in my language, I should have a space as separator or nothing.

How can I change that?!

share|improve this question
add comment

1 Answer 1

Use number_format_i18n( $number ). It will format the number with respect to the current blog’s language setting. It is a wrapper for PHP’s native number_format().

share|improve this answer
    
Thank you, your answer helped, but to fix this I had to change wp-includes/functions.php. –  PauloP Jul 4 '12 at 11:14
    
No, that’s wrong. The language separator is probably just missing in your language files. Add it there, do not create a fork of WordPress just for this. –  toscho Jul 4 '12 at 11:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.