Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Update:

Found the reason for the issue. The theme had this

add_action('init','ezgz_buffer');

function ezgz_buffer()
{
    ob_start('ob_gzhandler');
}

The above code enables gzip-compression if the visitor's browser can handle it.

Actual Question:

This is really really strange for me and I'm trying to figure out it for several hours.

W3 Total Cache plugin is installed and active. Preview mode disabled. Page Cache, Minify and Object Cache enabled. Enabled "Degug mode" for Page Cache, Minify, Object Cache.

Now I expect W3 Total cache to work and show debug log in page html but it doesn't :(

Site is loading as if W3TC doesn't exist.

Checks:

  • .htaccess file is in place with all the rules needed for W3 Total cache. (Pretty permalinks are working.)
  • W3 Total Cache plugin itself not showing any warning or error.
  • No other cache plugin enabled.
  • Also made sure I'm checking the correct site.
  • Server: Apache 2.2.22, PHP 5.3.13 (Hosted in media temple)
  • wp-config.php file has define('WP_CACHE', true);
  • Theme has wp_header() in header.php and wp_footer() in footer.php

Compatibility Test:

Server Modules & Resources:

Plugin Version: 0.9.2.4
PHP Version: 5.3.13 (PHP5 required for Minify, Rackspace CloudFiles, Microsoft Azure support)
Web Server: Apache
FTP functions: Installed (required for Self-hosted (FTP) CDN support)
Multibyte String support: Installed (required for Rackspace Cloud Files support)
cURL extension: Installed (required for Amazon S3, Amazon CloudFront, Rackspace CloudFiles support)
zlib extension: Installed (required for compression support)
Opcode cache: Not installed
Memcache extension: Not installed
HTML Tidy extension: Not installed (required for HTML Tidy minifier suppport)
Mime type detection: Installed (Fileinfo) (required for CDN support)
Hash function: Installed (hash) (required for NetDNA purge support)
Safe mode: Off
Open basedir: On: /nfs:/tmp:/usr/local:/etc/apache2/gs-bin
zlib output compression: Off
set_time_limit: Available
mod_deflate: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_env: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_expires: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_headers: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_mime: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_rewrite: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_setenvif: Not detected (required for Page Cache (enhanced mode) and Browser Cache)

WordPress Resources

_______________________/.htaccess: OK
_______________________/wp-content: OK
_______________________/wp-content/uploads/2012/06: OK
Fancy permalinks: /%year%/%monthnum%/%postname%/
WP_CACHE define: Defined (true)
URL rewrite: Enabled
Network mode: No

Clicked "emtpy all caches" several times (even though it doesn't seem to work).

No clue what so ever. I started it last night and I even thought its because I was sleepy. so took good sleep and still its the same, not just a dream.

share|improve this question

put on hold as off-topic by birgire, Johannes Pille, mrwweb, Pieter Goosen, ialocin yesterday

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Your question should be specific to WordPress. Generic PHP/JS/HTML/CSS questions might be better asked at Stack Overflow or another appropriate site of the Stack Exchange network. Third party plugins and themes are off topic." – birgire, Johannes Pille, mrwweb, Pieter Goosen, ialocin
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Thanks for sharing the reason. –  Pothi Jun 24 '12 at 1:06

2 Answers 2

mod_deflate: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_env: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_expires: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_headers: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_mime: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_rewrite: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
mod_setenvif: Not detected (required for Page Cache (enhanced mode) and Browser Cache)

Because none of these modules are installed in the server, W3 Total Cache could not do much. So, basically, "page cache" in (disk) enhanced mode won't work. You might try "page cache" in Disk: basic mode.

I'm not sure why "Object cache" and "Minify" didn't work, though.

share|improve this answer
    
Thanks. I did read that and switched back to Basic mode. –  tamilsweet Jun 23 '12 at 18:43
2  
The fact that the test script didn't detect them doesn't mean the modules are not installed: wordpress.org/support/topic/… –  Gaia May 31 at 9:45
    
You are right @Gaia. –  Pothi Jun 14 at 14:32
    
I added it as an answer. @Pothi –  Gaia Jun 15 at 10:09
    
Upvoted it now! –  Pothi Jun 16 at 6:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.