Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

So i migrated from localhost to my server, everything is working but my plugin cannot get the custom fields data anymore.

I get my custom fields this way:

$customs = get_post_custom($nodeid);
$customs['concertname'][0];

Then i tried get post meta and this also returns an empty string... The plugin i use is advanced custom fields, i use my own plugin to get the custom post data and put it in an xml. Local, everything is working like a charm. Plz help, this is for my finals :)

share|improve this question

1 Answer 1

When you moved the site, did you export and then re-import the content? I'm wondering if maybe the custom data just didn't make it into the live server's database.

The first place to look for whether that's the case would be either on the post's edit screen or within the database itself with PHPMyAdmin or something similar.

Also, I tend to use get_post_meta() and send the key along as an argument instead of getting all of the values and using the key to pull it from the array like get_post_custom() requires, you might try that and see if that helps.

share|improve this answer
    
First of all, thank you for willing to help. I tried get post meta and had the same result, the import is completely correct i just kept googling and tried some tutorials. Turns out i needed to update my permalinks. Tyvm tough! I just don't know why i need to update them :s –  Toon Van Dooren Jun 16 '12 at 14:20
    
Awesome, glad you got it figured out! –  Kevin Conboy Jun 16 '12 at 14:21
    
Can you tell me why i needed to update them? My module doesn't use any direct links or something –  Toon Van Dooren Jun 16 '12 at 14:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.