Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Edit: Fixed. I had an error in my permlink structure.

I have a problem with individual posts not showing with their URL.

I have set a custom category base in Permlinks called 'story'. I have a blogpost category called 'chapters', which has a subcategory 'chapter-1'.

Both category pages show fine, but when I want to go to the post (I have to, because I'm using the read more link) I get a 404 error, it can not find the post.

The post does show on the category pages, but the actual link, which wordpress creates as: site.com/story/chapters/chapter-1/post-name/ doesn't work. It looks good to me, that's how I want the URL structure to be.

What can I be doing wrong?

share|improve this question

closed as too localized by toscho Mar 9 '13 at 15:37

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

1 Answer 1

Your Permalink Settings should be:

/%category%/%postname%/

if you set it to subcategory only then you will have what you desire:

/category/sub-category/postname/

share|improve this answer
    
That's what I have, indeed. But it's not working. The correct and desired URL is being created for the post, but the post is not there/404. –  Gerben Jacobs Jun 16 '12 at 8:45
    
Can you share the link to your site? –  Abdus Jun 16 '12 at 20:09
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.