Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have just migrated my wordpress site from my laptop to my desktop. I get server error 500 when I try /localhost/wordpress/wp-admin. So I turned on WP_DEBUG and now I get a series of

Notice: Undefined variable: skype_mu_dir in /var/www/wordpress/wp-content/plugins/skype-online-status/skype-status.php on line 42 
Notice: Undefined variable: skype_mu_dir in /var/www/wordpress/wp-content/plugins/skype-online-status/skype-status.php on line 43 
Notice: Undefined variable: user in /var/www/wordpress/wp-content/plugins/wp-symposium/symposium_hooks_filters.php on line 553 
Notice: Undefined variable: user in /var/www/wordpress/wp-content/plugins/wp-symposium/symposium_hooks_filters.php on line 555 
Notice: Undefined variable: uid in /var/www/wordpress/wp-content/plugins/wp-symposium/symposium_hooks_filters.php on line 600 
Notice: Undefined variable: uid in /var/www/wordpress/wp-content/plugins/wp-symposium/symposium_hooks_filters.php on line 602 
Notice: Undefined variable: cache_needs_updating in /var/www/wordpress/wp-content/plugins/s2member/includes/classes/cache.inc.php on line 97 
Notice: Undefined index: level-1_label in /var/www/wordpress/wp-content/plugins/s2member/includes/classes/constants.inc.php on line 287 
Notice: Undefined index: contact_me_data in /var/www/wordpress/wp-content/plugins/contactme/contactmedotcom.php on line 34 
Fatal error: Class 'Memcache' not found in /var/www/wordpress/wp-content/plugins/flexicache/FlexiCache/Store/Memcache.php on line 63

A ls -l on /var/www shows

drwxr-xr-x  7 www-data www-data 4096 2012-06-13 21:35 wordpress

A ls -l on /var/www/wordpress shows

drwxr-xr-x 11 www-data www-data  4096 2012-06-13 19:24 wp-admin

A ps -ef | grep apache2 reports

prompt:/var/www/wordpress$ sudo ps -ef | grep apache2
root     14040     1  0 19:23 ?        00:00:00 /usr/sbin/apache2 -k start
www-data 14043 14040  0 19:23 ?        00:00:00 /usr/sbin/apache2 -k start
www-data 14044 14040  0 19:23 ?        00:00:01 /usr/sbin/apache2 -k start
www-data 14045 14040  0 19:23 ?        00:00:00 /usr/sbin/apache2 -k start
www-data 14046 14040  0 19:23 ?        00:00:00 /usr/sbin/apache2 -k start
www-data 14047 14040  0 19:23 ?        00:00:00 /usr/sbin/apache2 -k start
www-data 14048 14040  0 19:24 ?        00:00:00 /usr/sbin/apache2 -k start
www-data 14056 14040  0 19:24 ?        00:00:00 /usr/sbin/apache2 -k start

I wonder what I am missing. I am sure its something really small.

share|improve this question

1 Answer 1

Notices won't trigger a server 500 error. However, "fatal errors" will. From your logs above:

Fatal error: Class 'Memcache' not found in /var/www/wordpress/wp-content/plugins/flexicache/FlexiCache/Store/Memcache.php on line 63

This means you're running a plugin that depends on Memcache and your local system doesn't have Memcache support. Disable or remove the FlexiCache plugin, or install Memcache.


One other important thing to remember is that simply installing Memcache on your server isn't usually enough. PHP has to be compiled with support for it, or you need to manually load the PHP's Memcache extension. It's not bundled with PHP by default, though some hosts might install it for you.

share|improve this answer
    
I have installed memcached and loaded it too. Still same issue. –  Siddharth Jun 13 '12 at 17:55
    
I forgot to install php5-memcached on ubuntu. Works now. Thanks. –  Siddharth Jun 13 '12 at 18:04
    
See my edit. Remember, PHP's Memcache extension isn't bundled by default, so installing it is part of installing/configuring Memcache. –  EAMann Jun 28 '12 at 15:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.