Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a simple site with a few pages plus a blog. For some reason, the blog posts state comments are closed and I can't figure out why. I want to open the comments on all blog posts (and not offer comments on pages).

In the "edit post" screen, the "Comments" section just states "No comments yet." but doesn't offer any way to turn them on.

In settings>discussion, I have these:

ON Comment author must fill out name and e-mail
OFF Users must be registered and logged in to comment
OFF Automatically close comments on articles older than (14) days
ON Enable threaded (nested) comments levels (5) deep
ON Break comments into pages with (50) top level comments per page and ...

OFF Before a comment appears An administrator must always approve the comment
ON Comment author must have a previously approved comment

ON Hold a comment in the queue if it contains (1) or more links.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Have you tried go to "Posts" and checked the box next to the title and in the dropdown "Buld Actions" choose Edit and then apply, Comments and in the dropdown "Allow".

And also have added the screen in the post edit area on the tab in the header called "Screen Options" and checked the field called: Discussion?

And in settings->Discussion have you enabled "Allow people to post comments on new articles"?

share|improve this answer
    
1) +1: Your first paragraph helped fix it for the existing posts! I still need to change the default setting to allow comments though - any advice? –  Torben Gundtofte-Bruun Jun 12 '12 at 8:35
    
2) I'm sorry but I don't understand your second paragraph. In the "edit post" screen, I don't see anything called "screen options" nor "discussion". What did you mean? –  Torben Gundtofte-Bruun Jun 12 '12 at 8:36
    
If you editing a single post you have a tab in the right upper corner called: "Screen Options". Mark the box "Discussion" then you can turn on/off discussion on posts. And in settings-> discussion have you enabled "Allow people to post comments on new articles" –  Pontus Abrahamsson Jun 12 '12 at 8:43
    
D'OH! The setting "Allow people to post comments on new articles" was off...! Problem solved!! Thanks also for the help on the tab, that was so well hidden that I didn't see it :-) –  Torben Gundtofte-Bruun Jun 12 '12 at 9:11
    
Yeah, thats an easy thing to miss, Glad it works for you now! –  Pontus Abrahamsson Jun 12 '12 at 9:14

protected by Community Sep 9 at 13:34

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.